Bug 985368 - User cannot select multiple values from enumeration for operator "is contained in the a (comma separated) list" in Web Guided Decision Table
User cannot select multiple values from enumeration for operator "is containe...
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
5.x.x
Unspecified Unspecified
medium Severity medium
: ER6
: 6.0.0
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 07:05 EDT by Toshiya Kobayashi
Modified: 2014-08-06 16:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
repository_export_enum_dt.xml (35.35 KB, text/xml)
2013-07-17 07:10 EDT, Toshiya Kobayashi
no flags Details

  None (edit)
Description Toshiya Kobayashi 2013-07-17 07:05:36 EDT
Description of problem:

When you configure an Enumeration in Guvnor and use the filed in Web Guided Decision table, it shows a drop down list for cells. But you can choose only one value. Usually it's okay but in case of operator "is contained in the a (comma separated) list", you should want to select multiple values from the list.

Steps to Reproduce:
1. Import attached repository_export_enum_dt.xml
2. Open "dt1"
3. Click a cell of 'name' column

Actual results:

It shows a drop down list but you can choose only one value.

Expected results:

It shows a list box which allows you to select multiple values. And then it will be DRL like 

c : Country( name in ("Argentina", "Paraguay") )
Comment 1 Toshiya Kobayashi 2013-07-17 07:09:27 EDT
I wonder if I should file a community Guvnor JIRA because Guvnor 5.5.0 doesn't allow to select "is contained in the a (comma separated) list" if the field is configured as Enumeration in Guvnor.

Anyway I file this as a feedback from BRMS 5.3.1.
Comment 3 Toshiya Kobayashi 2013-07-17 07:26:26 EDT
https://issues.jboss.org/browse/GUVNOR-1858 has a similar concern but not directly related.
Comment 5 Prakash Aradhya 2013-08-06 15:54:29 EDT
This needs to be relooked at by engineering.
Comment 11 Bill DeCoste 2014-01-06 13:58:51 EST
I've got a customer who has reported this bug but they also showed that Enumerations were all broken not just "is contained in the a (comma separated) list". Can you confirm that this is a broader issue with the Beta?

Thanks -Bill
Comment 12 Toshiya Kobayashi 2014-01-06 21:49:51 EST
Hi Bill,

I have lightly tested 6.0.0.Beta and the latest ER7 build. Enumeration is working well to me. Could you ask the customer to raise a new support ticket so that we can identify the issue?

Regards,
Toshiya
Comment 15 Jiri Locker 2014-01-15 04:50:50 EST
Verified in ER7. The dropdown select box with enumerated values works as multi-selection list and so it is possible to select multiple values. The resulting rule source contains something like:
> Fact( field in ( "enum1", "enum2", "enum3" ) )

Note You need to log in before you can comment on or make changes to this bug.