Bug 985408 - [RFE] disable surfaces by default
[RFE] disable surfaces by default
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-qxl-driver-win (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Alon Levy
Desktop QE
: FutureFeature
Depends On:
Blocks: 1019470
  Show dependency treegraph
 
Reported: 2013-07-17 08:28 EDT by Alon Levy
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version: qxl-win-unsigned-0.1-18
Doc Type: Enhancement
Doc Text:
Previously, the DisabledSurfaces registry key was used to prevent performance issues when using the QXL driver to draw off screen surfaces. The DisabledSurfaces key is now replaced by SurfacesEnabled, and it is off by default.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:48:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Levy 2013-07-17 08:28:00 EDT
Right now we allow setting a special registry value to disable surfaces. This feature request is to change the default to off and change the registry key name to "SurfacesEnabled".

The new logic would be:

If there is no registry key then
 do not enable surfaces.
else
 enable surfaces
Comment 1 Alon Levy 2013-08-08 10:23:43 EDT
David,

 What is the proper way to say there is an unsigned version of the driver that fixes this bug, but no signed one yet? put it on MODIFIED with the qxl-win-unsigned version (as I'm just doing)?

Alon
Comment 7 errata-xmlrpc 2014-01-21 09:48:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0053.html

Note You need to log in before you can comment on or make changes to this bug.