Bug 985410 - Removes VM which fails to remove snapshot with RAM will stay in the system
Removes VM which fails to remove snapshot with RAM will stay in the system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity high
: ---
: 3.3.0
Assigned To: Arik
Tareq Alayan
virt
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-07-17 08:36 EDT by Ohad Basan
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version: is8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17308 None None None Never

  None (edit)
Description Ohad Basan 2013-07-17 08:36:06 EDT
Description of problem:

I am using an engine with three vms
only one of them has a nic
I am trying to add a nic to another vm and getitng a message Mac address already in use
The engine should, in case a new mac is added, pick another mac from the range defined in engine-config
Comment 2 Ohad Basan 2013-07-17 11:45:13 EDT
This bug was caused by a zombie vm with one nic. 
when tried to remove that vm > it did not remove it (because the vm was damaged because of another bug) but it did add the mac of the nic back to the pool.
Therefore the problem relates to the remove vm command which is not atomic
Comment 3 Mike Kolesnik 2013-07-18 10:14:47 EDT
Please look at line 6399 at the attached engine.log and see that the remove which is supposed to remove only from the DB calls VDSM verb which fails, causing the remove from DB to rollback, and keep the VM with NICs and everything in the system although it is supposed to be deleted.

The method involved is:
org.ovirt.engine.core.bll.VmCommand.removeVmSnapshots()

I propose that the VDSM code be run outside a transaction scope.
Comment 5 Tareq Alayan 2013-08-07 03:02:49 EDT
verified on is8.
Comment 6 Itamar Heim 2014-01-21 17:26:20 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:29:45 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.