Bug 985415 - openvpn does not resolve the remote fqdn right after reboot
openvpn does not resolve the remote fqdn right after reboot
Status: CLOSED DUPLICATE of bug 966281
Product: Fedora EPEL
Classification: Fedora
Component: openvpn (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 08:47 EDT by Dalibor Pospíšil
Modified: 2018-02-16 06:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-16 06:02:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dalibor Pospíšil 2013-07-17 08:47:16 EDT
Description of problem:
openvpn does not resolve the remote fqdn right after reboot and announce if in  logs.

After service is restarted in resolves ok. It seems like the name resolution occurs earlier then the DNS is set and it does not try it again or what.


Version-Release number of selected component (if applicable):
openvpn-2.3.1-3.el6.x86_64

How reproducible:
always on my machine

Steps to Reproduce:
1. create a vpn config for connection at the start of service
2. reboot
3. check /var/log/messages

Actual results:
/var/log/messages:
Jul 17 14:37:12 sopos openvpn[5039]: RESOLVE: Cannot resolve host address: <host>: Temporary failure in name resolution
Jul 17 14:37:17 sopos openvpn[5039]: RESOLVE: Cannot resolve host address: <host>: Temporary failure in name resolution
Jul 17 14:37:22 sopos openvpn[5039]: RESOLVE: Cannot resolve host address: <host>: Temporary failure in name resolution
...
every 5s appears new message


Expected results:
only few unsuccessful attempts
Comment 1 Björn Ruberg 2013-12-19 06:16:45 EST
I think this is a duplicate of #966281
Comment 2 David Sommerseth 2018-02-16 06:02:50 EST

*** This bug has been marked as a duplicate of bug 966281 ***

Note You need to log in before you can comment on or make changes to this bug.