Bug 985417 - spacewalk-splice-tool is not quiet during successful cron runs
spacewalk-splice-tool is not quiet during successful cron runs
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: Chris Duryee
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-17 08:54 EDT by Chris Duryee
Modified: 2013-10-01 07:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:12:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2013-07-17 08:54:41 EDT
Description of problem:

(from rwj@redhat.com)

>> The output from this cron job, which runs every 10 minutes spits out its
>> info to standard out. Cron's default behavior is to mail standard out to
>> the user who the cron job is invoked as; eventually leading to
>> /var/spool/mail/splice becoming large. We should probably redirect this
>> to a logfile or /dev/null unless it actually *is* an error. (No news is
>> good news)

Version-Release number of selected component (if applicable):  spacewalk-splice-tool-0.25-1

How reproducible: every time


Steps to Reproduce:
1. allow cron to execute sst

Actual results: output that fills /var/spool/mail/splice


Expected results: no output, unless there was an error
Comment 1 Chris Duryee 2013-07-30 11:30:52 EDT
85a34f2 splice-common 0.141+
Comment 2 Bryan Kearney 2013-08-02 14:51:51 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 4 Vitaly Kuznetsov 2013-08-26 08:30:18 EDT
Verified with spacewalk-splice-tool-0.40-1.el6sam:

# sudo -u splice /usr/bin/spacewalk-splice-checkin --spacewalk-sync
# echo $?
0
# sudo -u splice /usr/bin/spacewalk-splice-checkin --splice-sync
# echo $?
0
Comment 6 errata-xmlrpc 2013-10-01 07:12:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.