Bug 985422 - spacewalk-splice-tool ssh's to remote machine as root
spacewalk-splice-tool ssh's to remote machine as root
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: Splice Developers
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-17 09:01 EDT by Chris Duryee
Modified: 2013-10-01 07:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:12:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2013-07-17 09:01:47 EDT
Description of problem:

(from rwj@redhat.com)

>> Many of our customers strictly forbid directly SSH'ing via root. As
>> spacewalk-report needs to be run as root. I think an acceptable solution
>> would be to create an unprivileged user on the Satellite, and leverage
>> sudo to run the commands we need.

Version-Release number of selected component (if applicable): spacewalk-splice-tool-0.25-1

Additional info: This will likely require a code change as well as documentation updates to set up a non-root user to run the reports.
Comment 1 Chris Duryee 2013-07-25 16:34:02 EDT
spacewalk-splice-tool e9148e576 0.38
Comment 2 Bryan Kearney 2013-08-02 14:52:07 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 4 Vitaly Kuznetsov 2013-08-23 10:44:18 EDT
Verified with spacewalk-splice-tool-0.40-1.el6sam
Comment 6 errata-xmlrpc 2013-10-01 07:12:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.