Bug 985438 - error: conflicting types for ‘__libdwfl_find_elf_build_id’
error: conflicting types for ‘__libdwfl_find_elf_build_id’
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 09:30 EDT by Andrey Ponomarenko
Modified: 2013-08-14 22:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: elfutils-0.156-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-19 15:46:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible fix (572 bytes, patch)
2013-07-17 09:44 EDT, Frank Ch. Eigler
no flags Details | Diff

  None (edit)
Description Andrey Ponomarenko 2013-07-17 09:30:05 EDT
Description of problem:
dwfl_module_build_id.c:59:1: error: conflicting types for ‘__libdwfl_find_elf_build_id’
libdwflP.h:370:12: note: previous declaration of ‘__libdwfl_find_elf_build_id’ was here
make[2]: *** [dwfl_module_build_id.o] Error 1

Version-Release number of selected component (if applicable):
git latest from 2013-07-17

How reproducible:
always

Steps to Reproduce:
1. git clone git://git.fedorahosted.org/git/elfutils.git
2. cd elfutils
3. autoreconf -i -f
4. ./configure
5. make

Actual results:
Making all in libdwfl
make[2]: Entering directory `/home/admin/Install/elfutils/libdwfl'
gcc -D_GNU_SOURCE -DHAVE_CONFIG_H -DLOCALEDIR='"/home/admin/Install/elfutils/elfutils-latest/share/locale"' -I. -I..  -I. -I. -I../lib -I.. -I. -I./../libelf -I./../libebl -I./../libdw  -std=gnu99 -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2   -g -fPIC -MT dwfl_module_build_id.o -MD -MP -MF .deps/dwfl_module_build_id.Tpo -c -o dwfl_module_build_id.o dwfl_module_build_id.c
dwfl_module_build_id.c:59:1: error: conflicting types for ‘__libdwfl_find_elf_build_id’
libdwflP.h:370:12: note: previous declaration of ‘__libdwfl_find_elf_build_id’ was here
make[2]: *** [dwfl_module_build_id.o] Error 1
make[2]: Leaving directory `/home/admin/Install/elfutils/libdwfl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/admin/Install/elfutils'
make: *** [all] Error 2

Expected results:
no compilation errors

Additional info:
GCC 4.6.1, x86, GNU Linux (ROSA LTS)
Comment 1 Frank Ch. Eigler 2013-07-17 09:44:50 EDT
Created attachment 774788 [details]
possible fix

I could not reproduce the problem on F18/19/rawhide, but this patch may fix it at your site.
Comment 2 Jan Kratochvil 2013-07-19 15:46:20 EDT
Checked in upstream:
https://lists.fedorahosted.org/pipermail/elfutils-devel/2013-July/003137.html

This bug is reproducible only on i686, not on x86_64.

Sorry as it was caused by me.

Fedora elfutils-0.156 is going to be released these days.
Comment 3 Fedora Update System 2013-08-08 07:17:13 EDT
elfutils-0.156-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/elfutils-0.156-3.fc19
Comment 4 Fedora Update System 2013-08-14 22:38:13 EDT
elfutils-0.156-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.