Bug 985449 - p11-kit: upgrade to most recent UTF-8 specification
p11-kit: upgrade to most recent UTF-8 specification
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: p11-kit (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daiki Ueno
Hubert Kario
:
Depends On:
Blocks: 983512
  Show dependency treegraph
 
Reported: 2013-07-17 10:00 EDT by Florian Weimer
Modified: 2017-08-01 12:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: p11-kit-0.23.5-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:52:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-07-17 10:00:42 EDT
common/utf8.c:utf8_to_uchar() does not reject surrogate characters in the input, which are invalid in UTF-8.  UTF-8 was redefined in RFC 3629 so that code points in astral planes (unreachable with UTF-16) are no longer valid UTF-8.

The other conversion routines in that file do not seem to handle surrogate characters properly, either.

I'm not sure how relevant this is in practice, and if you can use platform conversion routines like iconv instead of rolling your own thing.
Comment 2 Stef Walter 2013-07-17 12:25:49 EDT
Agree with this. But punting to future release. The UTF-8 support is only used to generate OpenSSL symlinks when extracting. So not totally critical. Need to make sure that what we do here is compatible with how OpenSSL does this stuff.
Comment 11 errata-xmlrpc 2017-08-01 12:52:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1981

Note You need to log in before you can comment on or make changes to this bug.