Bug 985457 - [RFE] Volume resize / extend
[RFE] Volume resize / extend
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
medium Severity unspecified
: Upstream M2
: 4.0
Assigned To: Eric Harney
Yogev Rabl
https://blueprints.launchpad.net/cind...
: FutureFeature
Depends On:
Blocks: RHOS40RFE 988431
  Show dependency treegraph
 
Reported: 2013-07-17 10:15 EDT by Eric Harney
Modified: 2016-04-26 21:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.4.b2.el6ost
Doc Type: Enhancement
Doc Text:
With this release, Red Hat Enterprise Linux OpenStack Platform supports resizing a volume, using the extend_volume parameter. This would add an API call to specifically extend the size of an existing volume that is currently in an available state.
Story Points: ---
Clone Of:
: 988431 (view as bug list)
Environment:
Last Closed: 2013-12-19 18:55:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 32466 None None None Never

  None (edit)
Description Eric Harney 2013-07-17 10:15:55 EDT
Add support for resizing volumes, more accurately this would be extend_volume at least at first. This would add an API call to specifically extend the size of an existing volume that is currently in an available state.

https://blueprints.launchpad.net/cinder/+spec/volume-resize
Comment 3 Scott Lewis 2013-08-01 13:11:54 EDT
Changed Priority to match upstream
Comment 7 Dafna Ron 2013-11-28 13:45:45 EST
plan passed with 93% success.
Comment 8 Dafna Ron 2013-11-28 13:46:18 EST
root@cougar06 ~(keystone_admin)]# rpm -qa |grep cinder 
python-cinder-2013.2-2.el6ost.noarch
openstack-cinder-2013.2-2.el6ost.noarch
python-cinderclient-1.0.6-2.el6ost.noarch
[root@cougar06 ~(keystone_admin)]# 

tested with these packages
Comment 11 errata-xmlrpc 2013-12-19 18:55:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.