Bug 985461 - No mouse cursor in Spice/QXL-enabled guests
No mouse cursor in Spice/QXL-enabled guests
Status: NEW
Product: Virtualization Tools
Classification: Community
Component: virt-viewer (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 10:22 EDT by Erik Lotspeich
Modified: 2016-01-15 12:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Lotspeich 2013-07-17 10:22:40 EDT
Description of problem:

I have a guest that isn't using the guest QXL video driver. The mouse cursor works fine in that guest. All of my QXL-enabled VMs show no mouse cursor.

Note that the mouse works, just no cursor. I can click on stuff, but I just can't see the cursor.

This was working fine with exactly the same VM configuration when I was using virt-manager 0.9.5 and virt-viewer 0.5.6 compiled with GTK 2 support. It seems that this issue is somehow related to the move to GTK 3.

Version-Release number of selected component (if applicable):

Spice 0.12.3
virt-manager 0.10.0
virt-viewer 0.5.6

How reproducible:

Always

Steps to Reproduce:
1. Configure two VMs both with qxl/spice and with the tablet emulation device in addition to mouse
2. Install the guest qxl driver in only one of the VMs (the other will work in QXL's VGA compatibility mode)
3. Observe the results

Actual results:

The VM in VGA emulation shows the mouse cursor. The VM with the QXL driver shows no mouse cursor.

Expected results:

Mouse cursor shows in all video consoles

Additional info:

I have tried this both with virt-viewer and virt-manager and the problem shows in both. As I mentioned above, everything worked with the previous version of virt-manager (0.9.5) and virt-viewer compiled with GTK 2 support.
Comment 1 Erik Lotspeich 2013-07-30 10:09:22 EDT
I just upgraded to the latest libvirt 1.1.1 that was released today. That fixed this issue for me.
Comment 2 bjoernv 2016-01-02 11:20:20 EST
The issue still isn't fixed with latest sources:

Host:
- libvirt 1.3.0
- Qemu 2.4.0
- spice-protocol 0.12.10
- virt-viewer 2.00
- Kernel 4.3.3

Guest:
- spice-protocol 0.12.10
- xf86-video-qxl-0.1.4
- X.Org X Server 1.18.0
- Kernel 4.3.3

The cursor works, but is invisible. Sometimes a nearly transparent rectangle can be seen instead of a cursor.
Comment 3 nicolas 2016-01-15 12:55:38 EST
I can confirm that report.
guest : windows seven 
last qxl drivers
sdl2 display client 

=> no mouse cursor, 
so dual monitor is impossible

Regards, 
Nicolas

Note You need to log in before you can comment on or make changes to this bug.