Bug 985467 - Declarative model is migrated into plain DRL instead of format supported by data modeler
Declarative model is migrated into plain DRL instead of format supported by d...
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jervis Liu
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 10:40 EDT by Petr Široký
Modified: 2014-02-21 08:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 09:35:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Široký 2013-07-17 10:40:33 EDT
Description of problem:
The jcr2vfs migration tool migrates the old (5.3) declarative model into plain DRL. This should be fine from the engine point of view. However Guvnor 6.0 users won't be able to view/modify this model in data modeler and also won't be able to use the model in guided rules. 

I think the declarative model should be migrated into the format supported by from modeler, which in plain POJOs.

Version-Release number of selected component (if applicable):
6.0.0-DR6
Comment 1 Petr Široký 2013-07-18 09:35:50 EDT
I have just checked again and it seems I have been using DR5, because with DR6 the the POJOs are correctly created as described above. Sorry about that, closing the issue.

Note You need to log in before you can comment on or make changes to this bug.