Bug 985486 - [abrt] python-bugzilla-0.9.0-1.fc19: xmlrpclib.py:557:feed:ExpatError: syntax error: line 1, column 49
[abrt] python-bugzilla-0.9.0-1.fc19: xmlrpclib.py:557:feed:ExpatError: syntax...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:81ab2f9106ba41cf79f650e8ad5...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 11:24 EDT by Frantisek Kluknavsky
Modified: 2014-04-08 20:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-bugzilla-1.0.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-08 20:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.71 KB, text/plain)
2013-07-17 11:24 EDT, Frantisek Kluknavsky
no flags Details
File: core_backtrace (932 bytes, text/plain)
2013-07-17 11:24 EDT, Frantisek Kluknavsky
no flags Details
File: environ (2.95 KB, text/plain)
2013-07-17 11:24 EDT, Frantisek Kluknavsky
no flags Details

  None (edit)
Description Frantisek Kluknavsky 2013-07-17 11:24:24 EDT
Description of problem:
bugzilla info --component_owners=Fedora

Version-Release number of selected component:
python-bugzilla-0.9.0-1.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python -tt /usr/bin/bugzilla info --component_owners=Fedora
dso_list:       python-libs-2.7.5-3.fc19.x86_64
executable:     /usr/bin/bugzilla
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            19997

Truncated backtrace:
xmlrpclib.py:557:feed:ExpatError: syntax error: line 1, column 49

Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 1130, in <module>
    main()
  File "/usr/bin/bugzilla", line 1089, in main
    _do_info(bz, opt)
  File "/usr/bin/bugzilla", line 640, in _do_info
    include_fields=include_fields + ["components"])
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 521, in refresh_products
    for product in self._getproductinfo(**kwargs):
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 667, in _getproductinfo
    ret = self._proxy.Product.get_products(kwargs)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1578, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 166, in request
    return self.parse_response(stringio)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1467, in parse_response
    p.feed(data)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 557, in feed
    self._parser.Parse(data, 0)
ExpatError: syntax error: line 1, column 49

Local variables in innermost frame:
self: <xmlrpclib.ExpatParser instance at 0xa08830>
data: '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">\n<html><head>\n<title>502 Proxy Error</title>\n</head><body>\n<h1>Proxy Error</h1>\n<p>The proxy server received an invalid\r\nresponse from an upstream server.<br />\r\nThe proxy server could not handle the request <em><a href="/xmlrpc.cgi">POST&nbsp;/xmlrpc.cgi</a></em>.<p>\nReason: <strong>Error reading from remote server</strong></p></p>\n<hr>\n<address>Apache Server at bugzilla.redhat.com Port 443</address>\n</body></html>\n'
Comment 1 Frantisek Kluknavsky 2013-07-17 11:24:30 EDT
Created attachment 774821 [details]
File: backtrace
Comment 2 Frantisek Kluknavsky 2013-07-17 11:24:34 EDT
Created attachment 774822 [details]
File: core_backtrace
Comment 3 Frantisek Kluknavsky 2013-07-17 11:24:45 EDT
Created attachment 774823 [details]
File: environ
Comment 4 Cole Robinson 2013-07-17 13:26:08 EDT
Thanks for the report, but it says server error at bugzilla.redhat.com, so not python-bugzilla's fault AFAICT.
Comment 5 Frantisek Kluknavsky 2013-07-19 10:09:11 EDT
Unhandled exception, traceback and abrt alarm is the standard correct expected client-side behaviour in case of server error? Can it at least abrt ignore it?
Comment 6 Cole Robinson 2013-07-29 18:13:45 EDT
(In reply to Frantisek Kluknavsky from comment #5)
> Unhandled exception, traceback and abrt alarm is the standard correct
> expected client-side behaviour in case of server error? Can it at least abrt
> ignore it?

Yeah I didn't consider that. I've fixed upstream to catch and report HTTPErrors in /usr/bin/bugzilla so they won't tickle abrt.
Comment 7 Steve Tyler 2013-08-10 01:38:22 EDT
I just ran into this.

If this is fixed upstream, this bug should be CLOSED/UPSTREAM, not CLOSED/NOTABUG.

$ bugzilla query -c anaconda -l rsync
Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 1130, in <module>
    main()
  File "/usr/bin/bugzilla", line 1095, in main
    buglist = _do_query(bz, opt, parser)
  File "/usr/bin/bugzilla", line 613, in _do_query
    return bz.query(q)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 925, in query
    r = self._query(query)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 915, in _query
    return self._proxy.Bug.search(query)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1578, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 166, in request
    return self.parse_response(stringio)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1467, in parse_response
    p.feed(data)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 557, in feed
    self._parser.Parse(data, 0)
xml.parsers.expat.ExpatError: syntax error: line 1, column 49
$ 
$ rpm -q python-bugzilla
python-bugzilla-0.9.0-1.fc19.noarch
Comment 8 Cole Robinson 2013-08-15 12:11:47 EDT
Reopening to POST, since this error report is fixed upstream, but several people are seeing it so we should explicitly track when the fix lands in Fedora.
Comment 9 Fedora Update System 2014-03-25 18:44:20 EDT
python-bugzilla-1.0.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-bugzilla-1.0.0-1.fc19
Comment 10 Fedora Update System 2014-03-27 00:47:18 EDT
Package python-bugzilla-1.0.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-bugzilla-1.0.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4391/python-bugzilla-1.0.0-1.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2014-03-27 13:13:42 EDT
python-bugzilla-1.0.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-bugzilla-1.0.0-2.fc19
Comment 12 Fedora Update System 2014-04-08 20:56:02 EDT
python-bugzilla-1.0.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.