Bug 985492 - p11-kit: pthread_atfork handling
p11-kit: pthread_atfork handling
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: p11-kit (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.1
Assigned To: Daiki Ueno
Hubert Kario
:
Depends On:
Blocks: 983512
  Show dependency treegraph
 
Reported: 2013-07-17 11:40 EDT by Florian Weimer
Modified: 2017-08-01 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: p11-kit-0.23.5-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:52:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 84567 None None None Never

  None (edit)
Description Florian Weimer 2013-07-17 11:40:05 EDT
I'm not convinced that the pthread_atfork handling is correct.  The lock underlying p11_lock() needs to be acquired before the fork and released afterwards.  Otherwise, the reinitialization in the child process can fail if the a fork happens while the p11_lock has been taken by another thread.
Comment 2 Stef Walter 2013-07-17 12:47:08 EDT
pthread_atfork() is pretty much impossible to get correct. We simply try to do what the PKCS#11 spec says. But it's pretty bogus.

But I think this is too risky to fix in the stable branch. Unless you have objections I'll change to RHEL 7.1.
Comment 5 Stef Walter 2014-08-07 03:32:25 EDT
This needs work in Fedora before updating it in RHEL, bumping to RHEL 7.2
Comment 9 errata-xmlrpc 2017-08-01 12:52:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1981

Note You need to log in before you can comment on or make changes to this bug.