Bug 985500 - [RFE] Read-only volumes
[RFE] Read-only volumes
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
medium Severity unspecified
: Upstream M1
: 5.0 (RHEL 7)
Assigned To: Eric Harney
nlevinki
https://blueprints.launchpad.net/cind...
: FutureFeature
Depends On: 1087030
Blocks: 988435 RHOS50RFE
  Show dependency treegraph
 
Reported: 2013-07-17 11:48 EDT by Eric Harney
Modified: 2016-04-26 14:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.9.b3.el6ost
Doc Type: Enhancement
Doc Text:
With this release, you can now set a volume to read-only access. This feature allows you to give multiple users shared, secure access to the same data.
Story Points: ---
Clone Of:
: 988435 (view as bug list)
Environment:
Last Closed: 2014-07-08 11:30:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 38322 None None None Never
OpenStack gerrit 45171 None None None Never

  None (edit)
Description Eric Harney 2013-07-17 11:48:15 EDT
Provide the ability to attach volumes in the read-only mode. Read-only mode could be ensured by hypervisor configuration during the attachment.
Libvirt, Xen, VMware and Hyper-V support R/O volumes.

https://blueprints.launchpad.net/cinder/+spec/read-only-volumes
Comment 4 Scott Lewis 2013-08-01 13:37:12 EDT
Matched priority to upstream.
Comment 6 Eric Harney 2013-10-14 12:46:57 EDT
Server side landed in H-3, cinderclient changes still pending.  (Will be 1.0.7+.)
Comment 8 Dafna Ron 2013-11-21 04:52:12 EST
Eric, if only server side landed, how could I verify this bug? is it a code change only at this point or are there any system actions that I can do to test this?
Comment 12 Dafna Ron 2014-04-03 06:28:20 EDT
A new Blueprint was opened to allow create of a new volume as RO: 
https://blueprints.launchpad.net/cinder/+spec/new-ro-volume
Comment 15 Yogev Rabl 2014-04-23 09:12:37 EDT
The following bugs has been discovered in RDO:
Bug 1087030 - can't attach a read only volume to an instance
Bug 1084038 - cinder: please mark a volume as read-only
Comment 18 errata-xmlrpc 2014-07-08 11:30:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0852.html

Note You need to log in before you can comment on or make changes to this bug.