Bug 985503 - oo-accept-broker needs to check httpd_execmem
oo-accept-broker needs to check httpd_execmem
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miciah Dashiel Butler Masters
libra bugs
:
Depends On:
Blocks: 991223
  Show dependency treegraph
 
Reported: 2013-07-17 11:51 EDT by Miciah Dashiel Butler Masters
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The broker and management console both require the httpd_execmem SELinux Boolean to be enabled, but this was missing from the installation script. With this fix, the installation script was updated to correctly enable httpd_execmem for new installations. The oo-accept-broker command has also been updated to inform administrators if this setting is missing on an existing installation.
Story Points: ---
Clone Of:
: 991223 (view as bug list)
Environment:
Last Closed: 2013-08-05 13:20:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miciah Dashiel Butler Masters 2013-07-17 11:51:07 EDT
Description of problem:
oo-accept-broker needs to check the httpd_execmem SELinux Boolean.

The broker and the console both need httpd_execmem to be enabled (the broker and the console both use Passenger, which executes writable memory, and the console uses The Ruby Racer, which uses V8, which also executes writable memory).


Version-Release number of selected component (if applicable):
OSE 1.2.1.


How reproducible:
Easily.


Steps to Reproduce:
1. Run `setsebool httpd_execmem=false`.
2. Run `oo-accept-broker`.


Actual results:
Previously, oo-accept-broker did not report any problem with SELinux.


Expected results:
oo-accept-broker should report a failure because httpd_execmem is not enabled.


Additional info:
https://github.com/openshift/enterprise-server/pull/104 (merged).
https://github.com/openshift/origin-server/pull/3064 (awaiting review).
Bug 983686 (documentation bug).
Comment 2 Johnny Liu 2013-07-17 23:43:12 EDT
Verified this bug with 1.2/2013-07-17.1, and PASS.

# setsebool httpd_execmem=false
# getsebool httpd_execmem
httpd_execmem --> off
# oo-accept-broker -v
...
FAIL: SELinux boolean httpd_execmem is disabled -- run setsebool -P httpd_execmem=on
...
Comment 5 errata-xmlrpc 2013-08-05 13:20:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.