Bug 985506 - Gnome just hangs at after login
Gnome just hangs at after login
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-07-17 11:54 EDT by Steve Dickson
Modified: 2015-02-18 09:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-02-18 09:01:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Pic1: Login Screen (716.85 KB, image/jpeg)
2013-07-17 11:54 EDT, Steve Dickson
no flags Details
Blank screen after log in (627.62 KB, image/jpeg)
2013-07-17 11:55 EDT, Steve Dickson
no flags Details
List of gnome packages installed (4.64 KB, text/plain)
2013-07-17 11:56 EDT, Steve Dickson
no flags Details
List of "steved" processes running (2.83 KB, text/plain)
2013-07-17 11:58 EDT, Steve Dickson
no flags Details

  None (edit)
Description Steve Dickson 2013-07-17 11:54:54 EDT
Created attachment 774843 [details]
Pic1: Login Screen

Description of problem:
After logging (see first pic) I get a blank screen (See 2d pic)

Version-Release number of selected component (if applicable):
Freshly installation of Fedora 19

How reproducible:

Steps to Reproduce:
1. Login

Actual results:

Expected results:

Additional info:
Cinnamon, KDE, LXDE and OpenBox all work

Only Gnome hangs
Comment 1 Steve Dickson 2013-07-17 11:55:59 EDT
Created attachment 774844 [details]
Blank screen after log in
Comment 2 Steve Dickson 2013-07-17 11:56:57 EDT
Created attachment 774845 [details]
List of gnome packages installed
Comment 3 Steve Dickson 2013-07-17 11:58:15 EDT
Created attachment 774847 [details]
List of "steved" processes running
Comment 4 Ray Strode [halfline] 2013-07-17 14:35:36 EDT
So steved and I looked at this a bit today.  For some reason that we can't immediately figure out his locale is getting set to en_US instead of en_US.UTF-8.  This causes GnomeWallClock to return NULL instead of the current time, and that makes gnome-shell throw an exception.

we should handle that better and we should also figure out how his locale is getting set incorrectly.  the locale is right in gdm's session worker and wrong in gnome-session.  putting the correct locale in ~/.bash_profile fixes things, so it must be something in the xinit scripts though it wasn't apparently anything in /etc/X11/xinitrc.d
Comment 5 Samuel Sieb 2013-10-22 17:27:16 EDT
I just ran into this.  I have Gnome set to save my session, but it isn't really working.  So I setup my session, then used "gnome-session-quit --logout" to make sure it would save my session.  From the login screen I tried to reboot the laptop, but due to an unrelated kernel issue, I ended up having to hard power off the laptop.  When it came back up and I tried to login, I just get that screen.

On a related note, where are the session logs now?  I can't find them anywhere and so I have no idea where to look for what's happening.  Fortunately, I managed to find this bug.
Comment 6 Samuel Sieb 2013-10-22 17:29:21 EDT
However, my LANG environment variable seems to be fine, so it's probably not the same issue.
Comment 7 Samuel Sieb 2013-10-22 17:41:20 EDT
From another bug, I discovered about setting debug on gdm.  Is that really the only way to get session logs now?

Anyway, you can ignore my other comments.  It seems that because of the hard power off, my saved session desktop file got corrupted (filled with 0 bytes).  That's why it can't start gnome-shell.
Comment 8 Fedora End Of Life 2015-01-09 17:12:45 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2015-02-18 09:01:10 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.