Bug 985527 - [abrt] evolution-3.8.3-2.fc19: gtkhtml_editor_freeze: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.8.3-2.fc19: gtkhtml_editor_freeze: Process /usr/bin/evolut...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:7005d5d5c2da29164d8865fab73...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 12:49 EDT by M D
Modified: 2013-07-18 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 04:46:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (84.18 KB, text/plain)
2013-07-17 12:49 EDT, M D
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-17 12:49 EDT, M D
no flags Details
File: core_backtrace (1.51 KB, text/plain)
2013-07-17 12:49 EDT, M D
no flags Details
File: dso_list (26.43 KB, text/plain)
2013-07-17 12:49 EDT, M D
no flags Details
File: environ (1.77 KB, text/plain)
2013-07-17 12:50 EDT, M D
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-17 12:50 EDT, M D
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 627486 None None None Never

  None (edit)
Description M D 2013-07-17 12:49:44 EDT
Description of problem:
I tried to delete an email in the Junk folder. Evolution show a bunch of unknown operations in the status bar, hangs, then eventually crashes. This happens all the time.

Version-Release number of selected component:
evolution-3.8.3-2.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evolution
crash_function: gtkhtml_editor_freeze
executable:     /usr/bin/evolution
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (7 frames)
 #0 gtkhtml_editor_freeze at gtkhtml-editor.c:1678
 #1 composer_load_signature_cb at e-composer-private.c:1061
 #2 g_simple_async_result_complete at gsimpleasyncresult.c:777
 #3 mail_signature_combo_box_load_cb at e-mail-signature-combo-box.c:572
 #4 g_simple_async_result_complete at gsimpleasyncresult.c:777
 #5 complete_in_idle_cb_for_thread at gsimpleasyncresult.c:845
 #10 gtk_main at gtkmain.c:1156

Potential duplicate: bug 908998
Comment 1 M D 2013-07-17 12:49:50 EDT
Created attachment 774854 [details]
File: backtrace
Comment 2 M D 2013-07-17 12:49:53 EDT
Created attachment 774855 [details]
File: cgroup
Comment 3 M D 2013-07-17 12:49:56 EDT
Created attachment 774856 [details]
File: core_backtrace
Comment 4 M D 2013-07-17 12:49:58 EDT
Created attachment 774857 [details]
File: dso_list
Comment 5 M D 2013-07-17 12:50:04 EDT
Created attachment 774858 [details]
File: environ
Comment 6 M D 2013-07-17 12:50:12 EDT
Created attachment 774859 [details]
File: limits
Comment 7 Milan Crha 2013-07-18 04:46:50 EDT
Thanks for a bug report. There is filled a similar upstream bug [1], thus I'm moving this there. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

Interestingly, the evolution crashes in a code which is not related to Junk messages at all, it's related to a composer instead.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=627486
Comment 8 M D 2013-07-18 09:23:53 EDT
That's because when it freezes, sometimes composing a new message, then discarding the new message causes it to begin responding again.

And when I say freezes, what actually happens is that I click on an email, and the preview window attempts to display the message. A bunch of "Unknown Operations" will show up in the status bar. I can try to click on other email messages or go to other folders, but the preview window is frozen on attempting to load that first message. Trying to cancel everything doesn't fix it. I have found that sometimes if I compose a new message then discard it, the preview window will begin responding again. However, this is not always the case, and sometimes when doing this, evolution will just crash instead.

I have noticed this preview hanging seems to occur during html emails with lots of images.
Comment 9 Milan Crha 2013-07-18 13:10:14 EDT
It'll be good if you'll find an example message, where this behaviour will be reproducible, though I suppose the message usually contains private information, thus it's not completely shareable. In any case, if you would be able to get a backtrace of the frozen evolution, then it'll help to identify why it is frozen. You can get the backtrace with a command like this:
   $ gdb --batch --ex "t a a bt" -pid=`pidof evolution` &>bt.txt
only make sure you'll have installed also evolution-data-server and evolution debug info packages, of the same version like the binary packages. Before uploading the resulting bt.txt, please check it for private information too, it can sometimes expose your password, email addresses, server addresses and such (I usually search for "pass" (quotes for clarity only)).

Note You need to log in before you can comment on or make changes to this bug.