Bug 985547 - fedena installation error
fedena installation error
Status: CLOSED DUPLICATE of bug 963794
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Hiro Asari
libra bugs
: SupportQuestion, UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 13:53 EDT by bhavyakamboj
Modified: 2015-05-14 19:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 08:18:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bhavyakamboj 2013-07-17 13:53:00 EDT
Description of problem:
cannot install fedena

Version-Release number of selected component (if applicable):
ruby 1.8
mysql 5.1

How reproducible: during installation of this instant app


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Maintenance in progress

The OpenShift Online service is temporarily unavailable while we perform server maintenance. Please check the status page for updates.
Comment 1 Clayton Coleman 2013-08-21 16:48:56 EDT
This should now be resolved.
Comment 2 Tian Feng 2013-08-22 04:03:39 EDT
Test on PROD and devenv-stage_448, I cannot create a Fedena quickstarts via website. It will take more time to create and then return "Application creation is taking longer than expected. Please wait a few minutes, then refresh this page." 
After a while, the application will disapper.
Comment 3 Clayton Coleman 2013-08-23 15:25:51 EDT
Depending on the complexity of fedena it is probably hitting the deployment timeout limit.
Comment 4 Hiro Asari 2013-08-27 12:02:45 EDT
Could you explain how you are installing this?

If it is timing out when you create the application with '--from-code' flag, you can try creating an app, then replacing the code.

I consulted http://manichandrasekar.blogspot.in/2013/07/installing-fedena-on-openshift.html, which is slightly out of date, but should be instructive all the same.

The main difference between the instructions above and my procedure below is the removal of 'config.ru', which gets in the way during the process.

========
$ rhc app create fedena ruby-1.8 mysql-5.1
Application Options
-------------------
  Namespace:  fooooooooooo
  Cartridges: ruby-1.8, mysql-5.1
  Gear Size:  default
  Scaling:    no

Creating application 'fedena' ... done

  MySQL 5.1 database added.  Please make note of these credentials:
⋮

Run 'rhc show-app fedena' for more details about your app.
$ cd fedena
$ git remote add upstream -m master https://github.com/maninc/fedena.git
$ git pull -s recursive -X theirs upstream master
warning: no common commits
remote: Counting objects: 4465, done.
remote: Compressing objects: 100% (2722/2722), done.
remote: Total 4465 (delta 1535), reused 4456 (delta 1533)
Receiving objects: 100% (4465/4465), 5.31 MiB | 1.39 MiB/s, done.
Resolving deltas: 100% (1535/1535), done.
⋮

$ git rm config.ru
$ git commit -m 'no config.ru'
$ git push
⋮

remote: Starting Ruby cartridge
To ssh://521cc550b7a2d40d3a000001@fedena-fooooooooooo.dev.rhcloud.com/~/git/fedena.git/
   8942ed8..d79d2a6  master -> master
========

The initial push takes quite some time, since there is a lot of dependencies Bundler needs to resolve, and then a lot of gems to install. There is also migration to perform.

Once all of this is done, though, the application should be accessible. (There seems to be application errors in some functionalities, but they appear purely application errors, not OpenShift bugs.)

Try this, and let us know if we can be of further help.
Comment 5 Tian Feng 2013-08-27 22:43:18 EDT
Test on PROD, be able to create a fedena application successfully using rhc following the step above all.
But still fail to create on via web console. It will take more time to create and then return "Application creation is taking longer than expected. Please wait a few minutes, then refresh this page." 
After a while, the application will disappear.
Comment 6 Hiro Asari 2013-08-28 08:18:04 EDT
I apologize. I didn't see https://www.openshift.com/quickstarts/fedena.

The application's dependency is too large to fit within the current timeout used by the console (and its equivalent '--from-code' via command line).

I'll comment on the quickstart page.

I'm closing this as a duplicate of Bug 963794. See https://bugzilla.redhat.com/show_bug.cgi?id=963794#c4.

*** This bug has been marked as a duplicate of bug 963794 ***

Note You need to log in before you can comment on or make changes to this bug.