Bug 985601 - [abrt] wget-1.14-3.fc18: retrieve_url: Process /usr/bin/wget was killed by signal 11 (SIGSEGV)
[abrt] wget-1.14-3.fc18: retrieve_url: Process /usr/bin/wget was killed by si...
Status: CLOSED DUPLICATE of bug 981778
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
abrt_hash:a3e274bda3aa9954c3fbe55afbc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 16:44 EDT by Federico Leva
Modified: 2013-09-04 03:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 03:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (8.22 KB, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: cgroup (131 bytes, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: core_backtrace (302 bytes, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: dso_list (2.35 KB, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: environ (3.45 KB, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: maps (6.55 KB, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: open_fds (172 bytes, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: proc_pid_status (788 bytes, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details
File: var_log_messages (552 bytes, text/plain)
2013-07-17 16:44 EDT, Federico Leva
no flags Details

  None (edit)
Description Federico Leva 2013-07-17 16:44:01 EDT
Version-Release number of selected component:
wget-1.14-3.fc18

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        wget -nc -i /home/federico/et.txt
crash_function: retrieve_url
executable:     /usr/bin/wget
kernel:         3.9.6-200.fc18.i686.PAE
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #1 retrieve_url at retr.c:840
 #2 retrieve_from_file at retr.c:1075
Comment 1 Federico Leva 2013-07-17 16:44:10 EDT
Created attachment 774967 [details]
File: backtrace
Comment 2 Federico Leva 2013-07-17 16:44:14 EDT
Created attachment 774968 [details]
File: cgroup
Comment 3 Federico Leva 2013-07-17 16:44:17 EDT
Created attachment 774969 [details]
File: core_backtrace
Comment 4 Federico Leva 2013-07-17 16:44:21 EDT
Created attachment 774970 [details]
File: dso_list
Comment 5 Federico Leva 2013-07-17 16:44:29 EDT
Created attachment 774971 [details]
File: environ
Comment 6 Federico Leva 2013-07-17 16:44:33 EDT
Created attachment 774972 [details]
File: limits
Comment 7 Federico Leva 2013-07-17 16:44:39 EDT
Created attachment 774973 [details]
File: maps
Comment 8 Federico Leva 2013-07-17 16:44:43 EDT
Created attachment 774974 [details]
File: open_fds
Comment 9 Federico Leva 2013-07-17 16:44:49 EDT
Created attachment 774975 [details]
File: proc_pid_status
Comment 10 Federico Leva 2013-07-17 16:44:52 EDT
Created attachment 774976 [details]
File: var_log_messages
Comment 11 Tomáš Hozza 2013-07-18 03:26:30 EDT
Hi.

Can you please attach also the /home/federico/et.txt file? So I can reproduce
the bug and also test it if fixed.

Thanks!
Comment 12 Federico Leva 2013-07-18 13:14:31 EDT
Thanks for the answer. You obviously were going to need it but forgot to attach and now it's on another machine I don't have access to for a while.
The problem was caused by some lines consisting in URLs with special characters e.g. http://etherpad.wikimedia.org/wmukhack11Lør or http://etherpad.wikimedia.org/wmukhack11Søn , removing such lines let wget continue till the end.
The actual URL was actually weirder than that, e.g. http://web.archive.org/web/*/http://etherpad.wikimedia.org/wmukhack11Søn which seem to cause a loop.

I probably shouldn't input such URLs in the first place, perhaps wget might want to avoid dying so abruptly on them though.
Comment 13 Tomáš Hozza 2013-09-04 03:06:22 EDT
From what I tested and investigated, the issue should be fixed by fixing
Bug #981778. I was not able to reproduce it with the latest wget version,
but with the older version (wget-1.14-3.fc18) I was. Please update your
wget to the latest version (wget-1.14-5.fc18) if you didn't do so.

If you encounter this issue in the future, feel free to reopen this Bug
of open a new one.

*** This bug has been marked as a duplicate of bug 981778 ***

Note You need to log in before you can comment on or make changes to this bug.