Bug 985616 - Change in the 'called element' field on a reusable subprocess is not registered right away.
Change in the 'called element' field on a reusable subprocess is not registe...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 18:03 EDT by Marek Baluch
Modified: 2014-08-06 16:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:06:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
How to reproduce vid. (711.84 KB, video/webm)
2013-09-04 06:18 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-07-17 18:03:04 EDT
Description of problem:

If a process definition name is entered into the 'called element' field using the keyboard then it's not registered right away as the subprocess looses focus. When the + icon is clicked then the 'No Callable Element specified.' will be shown instead the process.

How to reproduce:

1) Create a new process definition
2) Add a reusable subprocess
3) Fillout the 'Called element' field (I used the 'UseInvoice' sample process)
4) Click the process canvas for the properties window to change
5) Click the + icon on the reusable process
6) Alert saying 'No Callable Element specified.' should appear.
Comment 1 Marek Baluch 2013-07-17 18:03:54 EDT
A second click on the '+' icon will open up the process as expected.
Comment 2 Tihomir Surdilovic 2013-07-24 10:34:09 EDT
I am unable to reproduce this issue. Created small video http://www.youtube.com/watch?v=SrleG10I3ss. 
Let me know if there is some other ways to reproduce.

Thanks.
Comment 3 Marek Baluch 2013-09-04 06:17:49 EDT
You could not reproduce the issue because you clicked the canvas before you clicked the '+' icon. Why is it required to click the canvas for the changes to take effect?
Comment 4 Marek Baluch 2013-09-04 06:18:15 EDT
Created attachment 793588 [details]
How to reproduce vid.
Comment 8 Tihomir Surdilovic 2013-11-12 13:59:37 EST
please retest with latest as for me its not reproducible (with your latest direction - no click on canvas).
Comment 9 Marek Baluch 2013-11-23 10:18:52 EST
Verified on ER5.

Note You need to log in before you can comment on or make changes to this bug.