Bug 985618 - Create an htop desktop entry
Create an htop desktop entry
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: htop (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On: 1039258
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 18:13 EDT by Mark Harfouche
Modified: 2014-01-17 18:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 18:08:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Harfouche 2013-07-17 18:13:11 EDT
Description of problem:
There is no desktop entry for htop.

I think it should either be installed by default with the htop package, or installed as a separate package.

Additional info:

This is basically the desktop file needed.
The last line doesn't accomplish anything with Gnome-Shell, but I think that is a gnome-shell issue.

[Desktop Entry]
Version=1.0
Name=Htop
Type=Application
Comment=Show System Processes
TryExec=htop
Exec=htop
Terminal=true
Icon=htop
Categories=ConsoleOnly;System;
GenericName=Process Viewer
StartupWMClass=htop
Comment 1 Dawid Gajownik 2014-01-17 17:48:58 EST
Hi Mark,

desktop file was removed because of the bug 689028.
Comment 2 Mark Harfouche 2014-01-17 17:56:17 EST
Hi Dawid,


Thanks for explaining.

I think htop/top is a very important task managing tool.

Would you considering adding it as a separate package?

Maybe htop-destkop.rpm depending on htop.rpm?
Comment 3 Rahul Sundaram 2014-01-17 18:08:44 EST
I think that is overkill.  htop is a command line program and command line programs don't ship with desktop files.  It is reserved for desktop graphical applications.   You are free to create your own desktop file and run it the way you prefer but shipping it in the repository is against the Fedora guidelines

Note You need to log in before you can comment on or make changes to this bug.