Bug 985656 - Missing /usr/bin/ruby193-ruby in package ruby193-ruby-1.9.3.448-38.el6.x86_64
Missing /usr/bin/ruby193-ruby in package ruby193-ruby-1.9.3.448-38.el6.x86_64
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 23:20 EDT by Gaoyun Pei
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The /usr/bin/ruby193-ruby wrapper script, which is required for several OpenShift Enterprise services, was removed from the base SCL package. To rebase to the latest SCL ruby193 package, this wrapper was required. With this fix, a new package was introduced to maintain consistency, allowing OpenShift Enterprise to run the latest SCL ruby193 packages.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:20:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2013-07-17 23:20:32 EDT
Description of problem:
File /usr/bin/ruby193-ruby wasn't put into package ruby193-ruby-1.9.3.448-38.el6.x86_64

Version-Release number of selected component (if applicable):
http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/1.2/2013-07-17.1
ruby193-ruby-1.9.3.448-38.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Set up OSE env, service httpd failed to start due to error:
*** Passenger ERROR (ext/common/ApplicationPool/../SpawnManager.h:221):
Could not start the spawn server: /usr/bin/ruby193-ruby: No such file or directory (2)

2. Check the content of ruby193-ruby-1.9.3.448-38.el6.x86_64:
[root@broker ~]# rpm -ql ruby193-ruby-1.9.3.448-38.el6.x86_64
/opt/rh/ruby193/root/usr/bin/erb
/opt/rh/ruby193/root/usr/bin/ruby
/opt/rh/ruby193/root/usr/bin/testrb
/opt/rh/ruby193/root/usr/share/doc/ruby193-ruby-1.9.3.448
/opt/rh/ruby193/root/usr/share/doc/ruby193-ruby-1.9.3.448/COPYING
/opt/rh/ruby193/root/usr/share/doc/ruby193-ruby-1.9.3.448/COPYING.ja
/opt/rh/ruby193/root/usr/share/doc/ruby193-ruby-1.9.3.448/GPL
/opt/rh/ruby193/root/usr/share/doc/ruby193-ruby-1.9.3.448/LEGAL
/opt/rh/ruby193/root/usr/share/man/man1/erb.1.gz
/opt/rh/ruby193/root/usr/share/man/man1/ruby.1.gz

Actual results:

Expected results:
/usr/bin/ruby193-ruby should exist in ruby193-ruby-1.9.3.448-38.el6.x86_64

Additional info:
Comment 2 Brenton Leanhardt 2013-07-18 08:23:55 EDT
I remember now that /usr/bin/ruby193-ruby was intentionally removed from the ruby SCL.  We'll need to pull the fixes from upstream that handle this.
Comment 3 Jason DeTiberus 2013-07-18 10:18:56 EDT
https://github.com/openshift/enterprise-server/pull/109
Comment 4 Jason DeTiberus 2013-07-18 11:03:15 EDT
ruby193-ruby-wrapper is no longer shipped with the scl ruby package, instead it is provided by ruby193-ruby-wrapper.  I've tagged this build and updated the dev puddle config.
Comment 5 Gaoyun Pei 2013-07-18 22:15:32 EDT
I found this issue was fixed on puddle 1.2/2013-07-18.4 
QE would verify this bug once its status moved to ON_QA.

After installing the OSE env, check file /usr/bin/ruby193-ruby
[root@broker ~]# ll  -Z /usr/bin/ruby193-ruby
-rwxr-xr-x. root root system_u:object_r:bin_t:s0       /usr/bin/ruby193-ruby

And it was provided by ruby193-ruby-wrapper
[root@broker ~]# rpm -qf /usr/bin/ruby193-ruby
ruby193-ruby-wrapper-0.0.1-2.el6op.noarch
Comment 6 openshift-github-bot 2013-07-19 00:22:31 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/f2689815f5184be1281c039e7cd78d70bb81756f
Bug 985656 - minor improvement for consistency in broker and console spec files

For some reason rhpkg really did not like the console spec's usage of
%{scl}-ruby-wrapper

Uploading: d79e6980b2997ea0f9b64fd2665f6d76  openshift-origin-console-1.5.22.tar.gz
error: line 32: Dependency tokens must begin with alpha-numeric, '_' or '/': Requires:      %{scl}-ruby-wrapper
error: query of specfile /home/bleanhar/git/rhpkg/openshift-origin-console/openshift-origin-console.spec failed, can't parse
Comment 7 Gaoyun Pei 2013-07-22 02:29:23 EDT
Verify this bug according to Comment 5
Comment 10 errata-xmlrpc 2013-08-05 13:20:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.