Bug 98566 - please add shred program to install image
please add shred program to install image
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-03 15:58 EDT by James Ralston
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-09 06:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2003-07-03 15:58:05 EDT
I frequently boot the Red Hat installation CD in order to run the GNU shred
utility on entire hard drives.  (Running shred is useless within ext3 and other
logging filesystem.)

However, the GNU shred utility isn't *on* the installation CD image.  Normally,
I get around that by copying it off of a floppy created on a running machine,
but that's hard to do on a laptop where either a floppy xor CD-ROM device can be
attached.

Since the coreutils RPM is on the installation CD, it's possible to use rpm2cpio
to extract it into /tmp, and then run it.

However, it would be much easier if the shred program were already in the
install image.  While space may be an issue, shred is only 35KB; it shouldn't
break the bank.

Thoughts?
Comment 1 Michael Fulbright 2003-07-09 14:45:44 EDT
Sure!

Fixed in our development tree.
Comment 2 James Ralston 2003-07-09 17:41:50 EDT
Excellent; thanks.

I'll test it out when the next RHL beta comes out.
Comment 3 James Ralston 2004-04-09 06:36:28 EDT
I've had no problems invoking shred from anaconda, for both FC1 and
RHEL 3.

Note You need to log in before you can comment on or make changes to this bug.