Bug 985672 - [abrt] cinnamon-1.9.1-16.fc19: ft_mem_qrealloc: Process /usr/bin/cinnamon was killed by signal 11 (SIGSEGV)
[abrt] cinnamon-1.9.1-16.fc19: ft_mem_qrealloc: Process /usr/bin/cinnamon was...
Status: CLOSED DUPLICATE of bug 678397
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
abrt_hash:5ca06548825af6f50012d071445...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 00:31 EDT by Robert Xu
Modified: 2013-11-15 14:17 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 14:17:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (218.75 KB, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: core_backtrace (6.47 KB, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: dso_list (18.85 KB, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: environ (1.59 KB, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: maps (81.26 KB, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: open_fds (4.30 KB, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: proc_pid_status (936 bytes, text/plain)
2013-07-18 00:31 EDT, Robert Xu
no flags Details
File: var_log_messages (3.80 KB, text/plain)
2013-07-18 00:32 EDT, Robert Xu
no flags Details
File: xsession_errors (7.27 KB, text/plain)
2013-07-18 00:32 EDT, Robert Xu
no flags Details

  None (edit)
Description Robert Xu 2013-07-18 00:31:06 EDT
Description of problem:
I set Cinnamon to use the top panel instead of the bottom. Then, I logged out and relogged in. Crash notification came up, Nemo's desktop did not load (no icons on the desktop), although Nemo's file manager is loading fine.

Version-Release number of selected component:
cinnamon-1.9.1-16.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        cinnamon --replace
crash_function: ft_mem_qrealloc
executable:     /usr/bin/cinnamon
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #3 ft_mem_qrealloc at /usr/src/debug/freetype-2.4.11/src/base/ftutil.c:154
 #4 ft_mem_realloc at /usr/src/debug/freetype-2.4.11/src/base/ftutil.c:101
 #5 Update_Max at /usr/src/debug/freetype-2.4.11/src/truetype/ttinterp.c:535
 #6 TT_Load_Context at /usr/src/debug/freetype-2.4.11/src/truetype/ttinterp.c:629
 #7 tt_size_run_fpgm at /usr/src/debug/freetype-2.4.11/src/truetype/ttobjs.c:757
 #8 tt_size_init_bytecode at /usr/src/debug/freetype-2.4.11/src/truetype/ttobjs.c:1012
 #9 tt_size_ready_bytecode at /usr/src/debug/freetype-2.4.11/src/truetype/ttobjs.c:1031
 #10 tt_loader_init at /usr/src/debug/freetype-2.4.11/src/truetype/ttgload.c:1929
 #11 TT_Load_Glyph at /usr/src/debug/freetype-2.4.11/src/truetype/ttgload.c:2182
 #12 FT_Load_Glyph at /usr/src/debug/freetype-2.4.11/src/base/ftobjs.c:695
Comment 1 Robert Xu 2013-07-18 00:31:11 EDT
Created attachment 775093 [details]
File: backtrace
Comment 2 Robert Xu 2013-07-18 00:31:14 EDT
Created attachment 775094 [details]
File: cgroup
Comment 3 Robert Xu 2013-07-18 00:31:17 EDT
Created attachment 775095 [details]
File: core_backtrace
Comment 4 Robert Xu 2013-07-18 00:31:22 EDT
Created attachment 775096 [details]
File: dso_list
Comment 5 Robert Xu 2013-07-18 00:31:28 EDT
Created attachment 775097 [details]
File: environ
Comment 6 Robert Xu 2013-07-18 00:31:31 EDT
Created attachment 775098 [details]
File: limits
Comment 7 Robert Xu 2013-07-18 00:31:42 EDT
Created attachment 775099 [details]
File: maps
Comment 8 Robert Xu 2013-07-18 00:31:48 EDT
Created attachment 775100 [details]
File: open_fds
Comment 9 Robert Xu 2013-07-18 00:31:55 EDT
Created attachment 775101 [details]
File: proc_pid_status
Comment 10 Robert Xu 2013-07-18 00:32:04 EDT
Created attachment 775102 [details]
File: var_log_messages
Comment 11 Robert Xu 2013-07-18 00:32:07 EDT
Created attachment 775103 [details]
File: xsession_errors
Comment 12 Behdad Esfahbod 2013-11-15 14:17:53 EST

*** This bug has been marked as a duplicate of bug 678397 ***

Note You need to log in before you can comment on or make changes to this bug.