Bug 985704 - maven-dependency-tree: Update to Eclipse Aether
maven-dependency-tree: Update to Eclipse Aether
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-dependency-tree (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 985674 985689
  Show dependency treegraph
 
Reported: 2013-07-18 01:24 EDT by Mikolaj Izdebski
Modified: 2013-07-25 00:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.1-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 00:04:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-07-18 01:24:35 EDT
Description of problem:
Package maven-dependency-tree currently Requires or BuildRequires aether.

Currently Fedora ships Sonatype Aether, but there are plans to migrate
to Eclipse Aether.  Because Eclipse Aether is incompatible with Sonatype Aether
maven-dependency-tree will likely have to be updated or patched.

Version-Release number of selected component (if applicable):
2.0-4
Comment 1 Mikolaj Izdebski 2013-07-22 07:29:22 EDT
Fixed in maven-dependency-tree-2.1-1
Comment 2 Mikolaj Izdebski 2013-07-25 00:04:45 EDT
I believe that this bug is fixed in maven-dependency-tree-2.1-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=436579

Note You need to log in before you can comment on or make changes to this bug.