Bug 985707 - shrinkwrap-resolver: Update to Eclipse Aether
shrinkwrap-resolver: Update to Eclipse Aether
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shrinkwrap-resolver (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks: 985674 985689 993304 1016381
  Show dependency treegraph
 
Reported: 2013-07-18 01:25 EDT by Mikolaj Izdebski
Modified: 2013-11-10 02:30 EST (History)
2 users (show)

See Also:
Fixed In Version: shrinkwrap-resolver-2.0.1-0.1.git1aba3c1fc9.fc20
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:30:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix broken aether wagon dependency (1.55 KB, patch)
2013-08-30 16:45 EDT, Gerard Ryan
no flags Details | Diff

  None (edit)
Description Mikolaj Izdebski 2013-07-18 01:25:25 EDT
Description of problem:
Package shrinkwrap-resolver currently Requires or BuildRequires aether.

Currently Fedora ships Sonatype Aether, but there are plans to migrate
to Eclipse Aether.  Because Eclipse Aether is incompatible with Sonatype Aether
shrinkwrap-resolver will likely have to be updated or patched.

Version-Release number of selected component (if applicable):
1.0.0-0.6.beta7
Comment 1 Marek Goldmann 2013-08-06 02:47:35 EDT
Reported upstream: https://issues.jboss.org/browse/SHRINKRES-140
Comment 2 Gerard Ryan 2013-08-30 16:45:05 EDT
Created attachment 792317 [details]
Fix broken aether wagon dependency

aether-connector-wagon is now aether-transport-wagon. It seems not possible to build against shrinkwrap-resolver in rawhide without updating this dependency.
Comment 3 Fedora Update System 2013-10-15 07:29:47 EDT
shrinkwrap-resolver-2.0.1-0.1.git1aba3c1fc9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/shrinkwrap-resolver-2.0.1-0.1.git1aba3c1fc9.fc20
Comment 4 Fedora Update System 2013-10-15 09:26:42 EDT
Package shrinkwrap-resolver-2.0.1-0.1.git1aba3c1fc9.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shrinkwrap-resolver-2.0.1-0.1.git1aba3c1fc9.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19110/shrinkwrap-resolver-2.0.1-0.1.git1aba3c1fc9.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-10 02:30:32 EST
shrinkwrap-resolver-2.0.1-0.1.git1aba3c1fc9.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.