Bug 985741 - AHCI as OS drive would make win8 guest cant enter the installation stage
AHCI as OS drive would make win8 guest cant enter the installation stage
Status: CLOSED DUPLICATE of bug 981723
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ademar Reis
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 02:46 EDT by Xiaoqing Wei
Modified: 2013-08-26 09:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 09:55:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pic (3.87 KB, image/png)
2013-07-18 02:46 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2013-07-18 02:46:29 EDT
Created attachment 775131 [details]
pic

Description of problem:

AHCI as OS drive would make win8 guest cant enter the installation stage

Version-Release number of selected component (if applicable):
virtio-win-prewhql-65
qemu-kvm-1.5.1-2.el7.x86_64
kernel-3.10.0-1.el7.x86_64
How reproducible:
100%

Steps to Reproduce:
1.qemu-kvm -monitor stdio    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130718-105638-MYsQzwyk,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130718-105638-MYsQzwyk,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130718-105638-MYsQzwyk,path=/tmp/seabios-20130718-105638-MYsQzwyk,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130718-105638-MYsQzwyk,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -device ahci,id=ahci,addr=0x5 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8-64.qcow2',if=none,id=ahci0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device ide-drive,bus=ahci.0,drive=ahci0 \
    -device e1000,netdev=idh7XpEs,mac='9a:d9:da:db:dc:dd',bus=pci.0,addr=0x3,id='id5ffBG4' \
    -netdev tap,id=idh7XpEs \
    -m 4096 \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 \
    -cpu 'SandyBridge' \
    -M pc \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/ISO/Win8/en_windows_8_enterprise_x64_dvd_917522.iso',if=none,id=drive-ide0-0-0,media=cdrom,format=raw \
    -device ide-drive,bus=ahci.1,drive=drive-ide0-0-0 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=drive-ide0-0-1,media=cdrom,format=raw \
    -device ide-drive,bus=ahci.2,drive=drive-ide0-0-1 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/virtio-win.iso',if=none,id=drive-ide0-1-0,media=cdrom,format=raw \
    -device ide-drive,bus=ahci.3,drive=drive-ide0-1-0 \
    -drive file='',if=none,id=fdc0-0-0,media=disk,readonly=off,format=raw \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off  \
    -enable-kvm


2.
3.

Actual results:
win8 guest just keep showing the MS running circle at the early booting stage
see pic

Expected results:
win8 guest should install success

Additional info:
if change the os drive to virtio-scsi, then can enter the installer


    -device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x6 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8-64.qcow2',if=none,id=virtio-scsi0-id0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device scsi-hd,drive=virtio-scsi0-id0 \
Comment 3 Ademar Reis 2013-08-13 15:23:00 EDT
Please re-test to verify if this is a dupe of bug 981723.
Comment 4 Xiaoqing Wei 2013-08-13 22:39:20 EDT
tested on qemu-kvm-1.5.2-3.el7,
this bug disappeared

Regards,
Xiaoqing.
Comment 5 Ademar Reis 2013-08-26 09:55:18 EDT

*** This bug has been marked as a duplicate of bug 981723 ***

Note You need to log in before you can comment on or make changes to this bug.