This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 985748 - 2 tests failing on big endian platforms
2 tests failing on big endian platforms
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: orthanc (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sebastien Jodogne
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-07-18 03:03 EDT by Dan Horák
Modified: 2013-11-08 22:34 EST (History)
3 users (show)

See Also:
Fixed In Version: orthanc-0.7.1-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 22:30:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2013-07-18 03:03:54 EDT
2 tests are failing when orthanc >= 0.6 is built on big endian arches like ppc and s390

...
[ RUN      ] PngWriter.ColorPattern
I0717 06:40:09.011315  3659 MemoryCache.cpp:103] Providing 42
I0717 06:40:09.011349  3659 MemoryCache.cpp:103] Providing 43
I0717 06:40:09.011366  3659 MemoryCache.cpp:103] Providing 45
I0717 06:40:09.011389  3659 MemoryCache.cpp:86] Removing cache entry for 45
I0717 06:40:09.011415  3659 MemoryCache.cpp:103] Providing 47
I0717 06:40:09.011431  3659 MemoryCache.cpp:86] Removing cache entry for 42
I0717 06:40:09.011447  3659 MemoryCache.cpp:103] Providing 44
I0717 06:40:09.011463  3659 MemoryCache.cpp:86] Removing cache entry for 43
I0717 06:40:09.011482  3659 MemoryCache.cpp:103] Providing 42
I0717 06:40:09.011497  3659 MemoryCache.cpp:86] Removing cache entry for 47
I0717 06:40:09.011512  3659 MemoryCache.cpp:86] Removing cache entry for 44
I0717 06:40:09.011531  3659 MemoryCache.cpp:86] Removing cache entry for 42
libpng error: No IDATs written into file
libpng error: No IDATs written into file
[       OK ] PngWriter.ColorPattern (1 ms)
[ RUN      ] PngWriter.Gray8Pattern
[       OK ] PngWriter.Gray8Pattern (0 ms)
[ RUN      ] PngWriter.Gray16Pattern
unknown file: Failure
Unknown C++ exception thrown in the test body.
[  FAILED  ] PngWriter.Gray16Pattern (0 ms)
[ RUN      ] PngWriter.EndToEnd
unknown file: Failure
Unknown C++ exception thrown in the test body.
[  FAILED  ] PngWriter.EndToEnd (1 ms)
...
[==========] 79 tests from 25 test cases ran. (237 ms total)
[  PASSED  ] 77 tests.
[  FAILED  ] 2 tests, listed below:
[  FAILED  ] PngWriter.Gray16Pattern
[  FAILED  ] PngWriter.EndToEnd
 2 FAILED TESTS


Version-Release number of selected component (if applicable):
orthanc-0.6.0-1.fc19

for full logs see
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1235285
or http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1104739
Comment 1 Sebastien Jodogne 2013-07-18 03:19:09 EDT
Thanks for pointing this problem! Unfortunately, I do not have access to big endian computers. Could someone indicate me how I could test Orthanc on big endian architectures?
Comment 2 Dan Horák 2013-07-18 03:50:56 EDT
There should be an option to get access to a ppc/ppc64 machine running Fedora. I'll let you know. Or you can jump to the #fedora-ppc channel on FreeNode IRC and talk to the right people directly.
Comment 3 Fedora Update System 2013-10-30 16:44:48 EDT
orthanc-0.7.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/orthanc-0.7.1-1.fc18
Comment 4 Fedora Update System 2013-10-30 16:54:40 EDT
orthanc-0.7.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/orthanc-0.7.1-1.fc19
Comment 5 Sebastien Jodogne 2013-10-30 17:09:13 EDT
I have just submitted a new package containing Orthanc 0.7.1, which should support big-endian architectures.

Unfortunately, I have not been able to launch by myself a mock build on the PPC64 computer you gave me access to (coho.fedora.osuosl.org), probably because of insufficient privileges. Please could someone try and build the new package on a big-endian computer? Many thanks for your help!
Comment 6 Fedora Update System 2013-10-31 23:54:52 EDT
Package orthanc-0.7.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing orthanc-0.7.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20425/orthanc-0.7.1-1.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-08 22:30:42 EST
orthanc-0.7.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-08 22:34:43 EST
orthanc-0.7.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.