Bug 985769 - SELinux is preventing /usr/sbin/prelink from 'setattr' accesses on the fifo_file .
SELinux is preventing /usr/sbin/prelink from 'setattr' accesses on the fifo_f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
abrt_hash:acebfd164045cf927368a763a79...
:
: 1035262 (view as bug list)
Depends On:
Blocks: 782468
  Show dependency treegraph
 
Reported: 2013-07-18 04:22 EDT by Martin Bříza
Modified: 2014-07-09 11:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-114.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:28:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bříza 2013-07-18 04:22:50 EDT
Description of problem:
Disconnected LAN cable in FIPS mode
SELinux is preventing /usr/sbin/prelink from 'setattr' accesses on the fifo_file .

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that prelink should be allowed setattr access on the  fifo_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep prelink /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:prelink_t:s0
Target Context                system_u:system_r:initrc_t:s0
Target Objects                 [ fifo_file ]
Source                        prelink
Source Path                   /usr/sbin/prelink
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           prelink-0.5.0-1.el7.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-63.el7.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-1.el7.x86_64 #1 SMP Tue Jul
                              9 12:25:09 EDT 2013 x86_64 x86_64
Alert Count                   10
First Seen                    2013-07-17 15:12:57 CEST
Last Seen                     2013-07-18 10:21:40 CEST
Local ID                      1b7f4a00-9cdf-46ec-a4f1-e93541336fca

Raw Audit Messages
type=AVC msg=audit(1374135700.740:1422): avc:  denied  { setattr } for  pid=16546 comm="prelink" name="" dev="pipefs" ino=200466 scontext=system_u:system_r:prelink_t:s0 tcontext=system_u:system_r:initrc_t:s0 tclass=fifo_file


type=SYSCALL msg=audit(1374135700.740:1422): arch=x86_64 syscall=fchown success=no exit=EACCES a0=1 a1=0 a2=0 a3=2 items=0 ppid=16545 pid=16546 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=prelink exe=/usr/sbin/prelink subj=system_u:system_r:prelink_t:s0 key=(null)

Hash: prelink,prelink_t,initrc_t,fifo_file,setattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.0-1.el7.x86_64
type:           libreport
Comment 2 Miroslav Grepl 2013-07-18 09:53:05 EDT
What does

# ps -eZ |grep initrc
Comment 3 Martin Bříza 2013-08-14 04:51:36 EDT
system_u:system_r:initrc_t:s0 512 ? 00:00:00 lsmd
Comment 5 Miroslav Grepl 2014-01-15 08:27:26 EST
It should be alrady fixed.
Comment 6 Miroslav Grepl 2014-01-15 08:28:38 EST
*** Bug 1035262 has been marked as a duplicate of this bug. ***
Comment 8 Ludek Smid 2014-06-13 09:28:12 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.