Bug 985793 - Allow property substitution in MDB via ctivationConfigProperty Annotation
Allow property substitution in MDB via ctivationConfigProperty Annotation
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
6.1.0
All Unspecified
unspecified Severity high
: DR0
: EAP 6.3.0
Assigned To: Chao Wang
Miroslav Novak
:
Depends On:
Blocks: 923905
  Show dependency treegraph
 
Reported: 2013-07-18 05:16 EDT by Carlo de Wolf
Modified: 2015-04-28 11:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This release of JBoss EAP 6 allows property substitution in Message Driven Beans via ActivationConfigProperty Annotation. Refer to the chapter on Message-Driven Beans in the EAP 6.3 `Developer Guide` for more information.
Story Points: ---
Clone Of: 923905
Environment:
Last Closed: 2014-06-28 11:44:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker EAP6-38 Major Closed [RFE] Enable property substitution in MDB via ActivationConfigProperty Annotation (PRODMGT-404) 2016-02-02 04:45 EST

  None (edit)
Comment 2 Jaikiran Pai 2013-09-03 08:37:10 EDT
Are we talking of EAP6 or EAP5? EAP 6 already has property substitution support in deployment descriptors.
Comment 3 Shaun Appleton 2013-09-03 09:46:41 EDT
from PRODMGT-404:

This request is to to be able to do the same within the annotation @ActivationConfigProperty

ie

@MessageDriven(name = "MDBMessageSendTxExample",
activationConfig =
{
@ActivationConfigProperty
(propertyName = "JndiParams", propertyValue = ${Arte.TestJMS1.JndiParams}

),
...

})

https://access.redhat.com/knowledge/docs/en-US/JBoss_Enterprise_Application_Platform/5/html-single/HornetQ_User_Guide/index.html#id807476
shows the use of @ActivationConfigProperty with hardcoded values
Comment 8 Dimitris Andreadis 2013-10-24 14:28:02 EDT
Assigning jpai@redhat.com EJB issues to david.lloyd@redhat.com. Please re-assign to Cheng or others as needed.
Comment 10 Kabir Khan 2014-01-30 05:12:41 EST
Linking https://issues.jboss.org/browse/EAP6-38 which seems to be a feature request for the same thing
Comment 11 Kabir Khan 2014-01-30 05:13:20 EST
https://github.com/jbossas/jboss-eap/pull/846
Comment 12 JBoss JIRA Server 2014-02-03 05:32:37 EST
Stuart Douglas <stuart.w.douglas@gmail.com> updated the status of jira EAP6-38 to Reopened
Comment 13 Kabir Khan 2014-02-05 16:53:16 EST
https://github.com/jbossas/jboss-eap/pull/872
Comment 14 Miroslav Novak 2014-02-28 13:31:28 EST
Verified in EAP 6.3.0.DR0.
Comment 15 Scott Mumford 2014-06-03 23:07:01 EDT
Marked as Enhancement and flagged for inclusion in the 6.3.0 Release Notes.
Comment 16 JBoss JIRA Server 2015-04-28 11:10:03 EDT
John Doyle <jdoyle@jboss.org> updated the status of jira EAP6-38 to Closed

Note You need to log in before you can comment on or make changes to this bug.