Bug 985815 - Some attributes of events from webadmin are not logged to engine.log
Some attributes of events from webadmin are not logged to engine.log
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.0
Assigned To: Spenser Shumaker
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 06:05 EDT by movciari
Modified: 2016-02-10 14:34 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 08:45:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description movciari 2013-07-18 06:05:00 EDT
Description of problem:
According to PRD: https://bugzilla.redhat.com/show_bug.cgi?id=966192
all attributes of events from webadmin events tab (advanced view) should be sent to log file, not just a subset

these attributes are missing:
Event ID, User (it's in event message but it should be in log as separate attribute too), Virtual Machine (name of VM is logged because it's in event message, but in advanced view it's separate attribute too), Template, Data Center, Storage, Cluster, Gluster Volume, Origin


Version-Release number of selected component (if applicable):
is6 (3.3.0-0.9)

How reproducible:
always

Steps to Reproduce:
1. Do any action (or more actions) that generates event (log in and run VM)
2. Go to webadmin events tab advanced view, check event attributes shown there
3. Go to engine.log, find line by AuditLogDirector for that event, check if all attributes from webadmin are there

Actual results:
from engine log:
2013-07-18 09:48:45,696 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-4-thread-50) [6839ed8a] Correlation ID: 6839ed8a, Job ID: 55f3ab6e-5926-4496-a6cd-a2e0fdd96dcd, Call Stack: null, Custom Event ID: -1, Message: VM test was started by admin@internal (Host: host322)

Expected results:
all event attributes should be on this line of log

Additional info:
Comment 1 Barak 2014-03-18 08:45:13 EDT
This bug is two generic.
The two mechanisms (the events and engine logs),
Hence the differences.

I acknowledge there  may be places there is a difference between various logs/events.

But since this bug is too generic I prefer having a separate bug on each case such a difference is found.

Hence moving to CLOSED WONTFIX (discussed with qe)

Note You need to log in before you can comment on or make changes to this bug.