This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 985870 - [RFE]: Add configurable time-delayed auto-delete for durable subscriptions
[RFE]: Add configurable time-delayed auto-delete for durable subscriptions
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
2.3
Unspecified Unspecified
medium Severity medium
: 3.1
: ---
Assigned To: Gordon Sim
Petr Matousek
: Documentation, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 08:03 EDT by Petr Matousek
Modified: 2015-04-14 09:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: qpid-cpp-0.30-7
Doc Type: Enhancement
Doc Text:
Auto-deleted queues are useful for preventing stale queues. However without some delay on the deletion, they prevent any reliability as the queue is lost as soon as a subscriber is disconnected, which may be due to some failure condition. A delay can be configured between the time a queue becomes eligible for auto-deletion and the time the deletion actually occurs. By configuring a queue with a non-zero autodelete timeout, a subscriber of the queue can re-subscribe after a failure (providing the subscriber does so within the configured limit) and not have messages lost along with the queue.
Story Points: ---
Clone Of:
Environment:
[Release Notes] Ready to go. [MPRG] Minor addition per Comment#16 to http://docbuilder.usersys.redhat.com/19948/#sect-Automatically_Deleted_Queues.
Last Closed: 2015-04-14 09:46:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5003 None None None Never
Apache JIRA QPID-6267 None None None Never
Apache JIRA QPID-6269 None None None Never
Apache JIRA QPID-6274 None None None Never
Apache JIRA QPID-6275 None None None Never
Apache JIRA QPID-6322 None None None Never
Apache JIRA QPID-6323 None None None Never
Apache JIRA QPID-6324 None None None Never

  None (edit)
Description Petr Matousek 2013-07-18 08:03:37 EDT
Description of problem:

Defining durable subscription queues to be auto-delete by default without a delayed time for the auto-delete do not make much sense.

It would be valuable to define a configurable time-delayed auto-delete that will be applied to subscription queues by default. This will protect the broker from clients that go off and leave stale subscriptions after a crash, but it still retain the general ability to survive a crash and re-establish subscription without lost messages.

Version-Release number of selected component (if applicable):
qpid-cpp-*-0.22-7

How reproducible:
n/a

Steps to Reproduce:
n/a

Actual results:
subscription queues are auto-delete by default when declared over amqp0-10
subscription queues are *not* auto-delete by default when declared over amqp1.0

Expected results:
subscription queues are *not* auto-delete by default when declared over amqp0-10 (see bug 985869)
There is a configurable time-delayed auto-delete applied on subscription queues by default.

Additional info:
Comment 1 Gordon Sim 2013-07-18 15:53:56 EDT
Fixed upstream: https://svn.apache.org/r1504622
Comment 30 Gordon Sim 2015-02-10 09:26:53 EST
Further fix: https://svn.apache.org/r1658581
Comment 38 Petr Matousek 2015-04-02 11:10:07 EDT
This issue has been implemented and the ocumentation was updated accordingly.
Verified on rhel6.6 (x86_64 and i386) and rhel7 (x86_64).

Packages:
  qpid-cpp-*-0.30-8

-> VERIFIED
Comment 40 errata-xmlrpc 2015-04-14 09:46:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html

Note You need to log in before you can comment on or make changes to this bug.