Bug 985873 - [swift-services] gluster-swift services has references to "/usr/share/openstack-swift/functions"
[swift-services] gluster-swift services has references to "/usr/share/opensta...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.1
x86_64 Linux
low Severity high
: ---
: RHGS 2.1.0
Assigned To: Luis Pabón
pushpesh sharma
:
Depends On:
Blocks: 973578 974560 985807
  Show dependency treegraph
 
Reported: 2013-07-18 08:09 EDT by pushpesh sharma
Modified: 2016-11-08 17:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2013-07-18 08:09:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.[root@dhcp207-210 ~]# service --all status 
glusterd (pid  1441) is running...
/etc/init.d/gluster-swift-account: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-account-auditor: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-account-reaper: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-account-replicator: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-container: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-container-auditor: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-container-replicator: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-container-updater: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-object: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-object-auditor: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-object-expirer: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-object-replicator: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-object-updater: line 18: /usr/share/openstack-swift/functions: No such file or directory
/etc/init.d/gluster-swift-proxy: line 18: /usr/share/openstack-swift/functions: No such file or directory


2. 
[root@dhcp207-210 ~]# rpm -qa|grep gluster
gluster-swift-object-1.8.0-6.3.el6rhs.noarch
vdsm-gluster-4.10.2-22.7.el6rhs.noarch
gluster-swift-plugin-1.8.0-2.el6rhs.noarch
glusterfs-geo-replication-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-1.8.0-6.3.el6rhs.noarch
glusterfs-server-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-proxy-1.8.0-6.3.el6rhs.noarch
gluster-swift-account-1.8.0-6.3.el6rhs.noarch
glusterfs-rdma-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-container-1.8.0-6.3.el6rhs.noarch


3.

Actual results:


Expected results:


Additional info:
Comment 2 Luis Pabón 2013-07-19 11:53:37 EDT
This will be on HOLD until after August first.  For now, bug 983403 will resolve the symptom recorded in this bug.  The real resolution will either be to create our own rpms for OpenStack or use RHOS OpenStack RPMs.  This decision will not be made until August 1.
Comment 3 Sahina Bose 2013-07-22 05:52:21 EDT
Update - Service start and status are not working either.

service gluster-swift-account status
--> returns
/etc/init.d/gluster-swift-account: line 18: /usr/share/openstack-swift/functions: No such file or directory

service gluster-swift-account start
--> returns
/etc/init.d/gluster-swift-account: line 18: /usr/share/openstack-swift/functions: No such file or directory
Comment 4 Luis Pabón 2013-07-28 17:06:20 EDT
Issue solved by redoing the gluster-swift RPM.  Instead of renaming all the installed files from openstack-swift-* to gluster-swift-*, now it installs the files verbatim.

Fix in gluster-swift-*-1.8.0-6.7*.rpm

More info here:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6093508
Comment 5 pushpesh sharma 2013-08-05 05:30:57 EDT
All references to gluster-swift services must be replaced with openstack-swift.

[root@luigi ~]# service --status-all |grep swift
openstack-swift-account (pid  3500) is running...
openstack-swift-account-auditor is stopped
openstack-swift-account-reaper is stopped
openstack-swift-account-replicator is stopped
openstack-swift-container (pid  3499) is running...
openstack-swift-container-auditor is stopped
openstack-swift-container-replicator is stopped
openstack-swift-container-updater is stopped
openstack-swift-object (pid  3501) is running...
openstack-swift-object-auditor is stopped
openstack-swift-object-replicator is stopped
openstack-swift-object-updater is stopped
openstack-swift-proxy (pid  3498) is running...


[root@luigi ~]# rpm -qa|grep swift
gluster-swift-container-1.8.0-6.11.el6rhs.noarch
gluster-swift-1.8.0-6.11.el6rhs.noarch
gluster-swift-proxy-1.8.0-6.11.el6rhs.noarch
gluster-swift-account-1.8.0-6.11.el6rhs.noarch
gluster-swift-object-1.8.0-6.11.el6rhs.noarch
gluster-swift-plugin-1.8.0-4.el6rhs.noarch
Comment 8 Scott Haines 2013-09-23 18:32:32 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.