Bug 985891 - Can't create bridgeless (non vm) network.
Can't create bridgeless (non vm) network.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
high Severity urgent
: ---
: 3.3.0
Assigned To: Dan Kenigsberg
Meni Yakove
network
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 08:49 EDT by Meni Yakove
Modified: 2016-02-10 14:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:29:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine and vdsm logs (1008.51 KB, application/zip)
2013-07-18 08:51 EDT, Meni Yakove
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17085 None None None Never

  None (edit)
Description Meni Yakove 2013-07-18 08:49:36 EDT
Description of problem:
VDSM fails to create bridgeless (non vm) network.
After it fails if vdsmd service is restart it stack on:

Thread-13::DEBUG::2013-07-13 17:40:36,608::BindingXMLRPC::979::vds::(wrapper) client [10.35.161.86]::call getCapabilities with () {}
Thread-13::DEBUG::2013-07-13 17:40:36,608::BindingXMLRPC::986::vds::(wrapper) return getCapabilities with {'status': {'message': 'Recovering from crash or Initializing', 'code': 99}}

and the host is in Initializing on rhevm.

Version-Release number of selected component (if applicable):
vdsm-4.12.0-rc1.12.git8ee6885.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create net1(non vm) on dc and attach it to cluster 
2.open setupnetwork and attach net1 to interface


Actual results:
net1 bridgeless network wasn't created

Expected results:
net1 bridgeless network created

Additional info:
from vdsm log:
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 984, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 413, in setupNetworks
    return api.setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/API.py", line 1259, in setupNetworks
    supervdsm.getProxy().setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/supervdsm.py", line 57, in __call__
    raise ex
IndexError: list index out of range


from virsh net-dumpxml:
<network>
  <name>vdsm-sw1</name>
  <uuid>28829a4f-babc-3193-a94e-6c055874cdb9</uuid>
  <forward mode='passthrough'/>
</network>
Comment 1 Meni Yakove 2013-07-18 08:51:31 EDT
Created attachment 775300 [details]
engine and vdsm logs
Comment 2 Meni Yakove 2013-07-18 09:34:34 EDT
removeing net1 (non vm) network from libvirt using virsh solve the vdsm service problem ({'message': 'Recovering from crash or Initializing', 'code': 99}})
Comment 6 Meni Yakove 2013-07-26 03:55:48 EDT
vdsm-4.12.0-rc3.12.git139ec2f.el6ev.x86_64
Comment 7 Charlie 2013-11-27 19:35:32 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 Dan Kenigsberg 2013-12-02 12:30:02 EST
This issue was introduced and solved during the rhev-3.3 development cycle. No reason to report it to customers.
Comment 9 errata-xmlrpc 2014-01-21 11:29:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.