Bug 985893 - do not use putenv
do not use putenv
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie (Show other bugs)
6.5
x86_64 Unspecified
low Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
qe-baseos-daemons
abrt_hash:59c148d7f1015e6865c5590e502...
: Patch
Depends On: 971516
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 09:00 EDT by Marcela Mašláňová
Modified: 2013-11-21 17:24 EST (History)
6 users (show)

See Also:
Fixed In Version: cronie-1.4.4-9.el6
Doc Type: Bug Fix
Doc Text:
Cause: Change path didn't work all the time properly, because puten system call was used. Consequence: The system call putenv might lead to segfault. Fix: The system call setenv is used instead of putenv. Result: No segfault because of changing path by putenv.
Story Points: ---
Clone Of: 971516
Environment:
Last Closed: 2013-11-21 17:24:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2013-07-18 09:00:32 EDT
+++ This bug was initially created as a clone of Bug #971516 +++

Version-Release number of selected component:
cronie-1.4.10-4.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/sbin/crond -n
crash_function: spt_copyenv
executable:     /usr/sbin/crond
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 spt_copyenv at setproctitle.c:98
 #1 spt_init at setproctitle.c:172
 #2 call_init at dl-init.c:82
 #3 _dl_init at dl-init.c:131
 #4 dl_open_worker at dl-open.c:566
 #5 _dl_catch_error at dl-error.c:177
 #6 _dl_open at dl-open.c:656
 #7 dlopen_doit at dlopen.c:66
 #8 _dl_catch_error at dl-error.c:177
 #9 _dlerror_run at dlerror.c:163

--- Additional comment from Terry Polzin on 2013-06-06 19:06:21 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:25 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:28 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:31 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:34 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:38 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:41 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:44 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:47 CEST ---



--- Additional comment from Terry Polzin on 2013-06-06 19:06:50 CEST ---



--- Additional comment from Fedora Update System on 2013-06-11 20:56:49 CEST ---

cronie-1.4.10-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cronie-1.4.10-5.fc19

--- Additional comment from Fedora Update System on 2013-06-12 21:11:27 CEST ---

Package cronie-1.4.10-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cronie-1.4.10-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10687/cronie-1.4.10-5.fc19
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-06-14 06:52:39 CEST ---

cronie-1.4.10-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 errata-xmlrpc 2013-11-21 17:24:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1681.html

Note You need to log in before you can comment on or make changes to this bug.