Bug 985898 - Too many windows open with fullscreen=auto-conf
Too many windows open with fullscreen=auto-conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-07-18 09:10 EDT by Tomas Jamrisko
Modified: 2014-01-21 09:46 EST (History)
7 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.6-9.el6_4
Doc Type: Bug Fix
Doc Text:
In autoconf mode, remote-viewer opened as many windows as configured guest's displays. If the guest has more configured displays than the number of client's monitors, extra windows will be opened. Now, the extra guest displays are hidden. In autoconf mode, the number of fullscreen windows matches the number of monitors.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:46:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2013-07-18 09:10:49 EDT
Description of problem:
Virt-viewer sometimes opens one too many windows when fullscreen is configured when connecting to a windows guest

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.3-28

How reproducible:
100 %

Steps to Reproduce:
1. Connect to a windows guest without fullscreen autoconf
2. Open several additional monitors (more than physical on client)
3. close the session.
4. Connect to the guest again, this time with autoconf enabled

Actual results:
First n monitors will be correctly open on first n physical monitors, but at least one addition guest monitor will be open partially overlapping one of the others

Expected results:
Guest should have at most the same number of monitors as client.
Comment 1 Marc-Andre Lureau 2013-07-18 12:21:20 EDT
grr, hard bug to fix it seems.

there is no relation between client monitor config request, and current received configuration (in fact 1 request, can trigger n server monitor config reply that may be related or not), so we will have to hack something that might have undesirable side effects. So what we could do is make sure to disable monitors that don't fit in fullscreen, I have been trying to do that...

The bug doesn't seem to easy to reproduce with the linux build, I think it shows that this is somehow also racy.
Comment 2 Marc-Andre Lureau 2013-07-18 13:12:57 EDT
weird, I can't reproduce on XP either, but with win7 100%..
Comment 3 Marc-Andre Lureau 2013-07-18 14:22:06 EDT
Sent patch series fixing this:
https://www.redhat.com/archives/virt-tools-list/2013-July/msg00120.html
Comment 5 Tomas Jamrisko 2013-10-31 10:29:25 EDT
Tried 0.5.6-9 and it doesn't fix it. Same issue.
Comment 6 Marc-Andre Lureau 2013-10-31 13:13:03 EDT
(In reply to Tomas Jamrisko from comment #5)
> Tried 0.5.6-9 and it doesn't fix it. Same issue.

are you sure you tried with auto-conf? if not autoconf, it's expected we open as many windows as guest monitors.
Comment 8 Charlie 2013-11-27 20:26:34 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 09:46:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.