Bug 985927 - rhevm-websocket-proxy - open firewall port?
rhevm-websocket-proxy - open firewall port?
Status: CLOSED DUPLICATE of bug 985945
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 10:09 EDT by Jiri Belka
Modified: 2013-07-18 11:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 11:26:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-07-18 10:09:48 EDT
Description of problem:

After installing rhevm-websocket-proxy and starting it, I cannot access it as iptables is not updated.

It would be nice to make some kung-fu to allow rhevm-websocket-proxy work out of the box without manual intervention (minimum for default 6100 port).

# rpm --scripts -q rhevm-websocket-proxy
postinstall program: /bin/sh
preuninstall scriptlet (using /bin/sh):

if [ $1 -eq 0 ] ; then
    service ovirt-websocket-proxy stop > /dev/null 2>&1 || true
fi
postuninstall program: /bin/sh

Version-Release number of selected component (if applicable):
is6

How reproducible:
100%

Steps to Reproduce:
1. install clean rhevm
2. install rhevm-websocket-proxy
3. start ovirt-websocket-proxy and try to connect from client to hosts' 6100 port

Actual results:
blocked by FW

Expected results:
working without manual intervention (we are enterprise) :-)

Additional info:

maybe whole FW should be changed, what about this?
* rhevm-setup would create new chain for each its apps (engine, websocket-proxy)
* as engine is what is installed by default, populate with rules
* when starting websocket-proxy get port and put into rules into its own chain

just thinking loudly...
Comment 1 Alon Bar-Lev 2013-07-18 11:26:43 EDT

*** This bug has been marked as a duplicate of bug 985945 ***

Note You need to log in before you can comment on or make changes to this bug.