This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 985938 - [RFE] store checksum type on ISOs
[RFE] store checksum type on ISOs
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: iso-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 10:33 EDT by Dennis Gregorovic
Modified: 2015-02-28 18:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 20:11:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 201 None None None Never

  None (edit)
Description Dennis Gregorovic 2013-07-18 10:33:36 EDT
Units of type ISO have a checksum field.  Please add a checksum_type field as well.
Comment 1 Michael Hrivnak 2013-07-18 11:00:22 EDT
It looks like the manifest files on the CDN also don't include a checksum type, so we aren't able to determine what the type is. 

http://download.devel.redhat.com/cds/prod/content/dist/rhel/server/6/6Server/x86_64/iso/PULP_MANIFEST

I understand that you basically own this file's format, so perhaps we should start by adding it there, and then it'll be easy for pulp to grab it and save it.

Of course we'll have to be careful to make sure current pulp doesn't fail to parse the file once the checksum type is added, so we should collaborate on the plan and make sure pulp is able to handle it.
Comment 3 Jay Dobies 2013-11-01 15:03:17 EDT
Is this still needed?
Comment 4 Dennis Gregorovic 2013-11-01 15:12:22 EDT
Yes.  It's not urgent, but I would like this added at some point.
Comment 6 Brian Bouterse 2015-02-18 20:11:34 EST
Moved to https://pulp.plan.io/issues/201

Note You need to log in before you can comment on or make changes to this bug.