Bug 985943 - [RFE] Incorporate detailed LDAP/AD and DNS Configuration information into Deployment Guide
[RFE] Incorporate detailed LDAP/AD and DNS Configuration information into Dep...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
1.2.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Alex Dellapenta
Bilhar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 10:42 EDT by dchia
Modified: 2017-03-08 12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-12 10:48:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dchia 2013-07-18 10:42:49 EDT
Description of problem:


The sections detailing AD/LDAP integration and configuration would be useful to see in the deployment guide in some form.

There is also some helpful information around DNS in there as well that should go into the deployment guide:

"BIND is an integral part of a successful OpenShift Enterprise deployment / environment. OpenShift Enterprise uses a RubyGem called dnsruby to issue dynamic updates to the DNS environment. The requirement that allows this functionality is that the DNS environment supports RFC 2136 (Dynamic DNS Updates). Any DNS implementation that supports RFC 2136 will work in a OpenShift Environment, however, this reference architecture uses BIND."

[1] http://www.redhat.com/resourcelibrary/reference-architectures/deploying-and-managing-a-private-paas-with-openshift-enterprise
Comment 2 Alex Dellapenta 2014-12-12 10:48:31 EST
Broker LDAP section was updated per BZ#929182:

https://access.redhat.com/documentation/en-US/OpenShift_Enterprise/2/html-single/Deployment_Guide/index.html#LDAP_Authentication

Information on LDAP auth for the Admin Console was added here:

https://access.redhat.com/documentation/en-US/OpenShift_Enterprise/2/html-single/Deployment_Guide/index.html#Configuring_Authentication_for_the_Administration_Console

Information on BIND usage has also been updated since this BZ was opened, and sections on the various DNS plug-ins have also been added:

https://access.redhat.com/documentation/en-US/OpenShift_Enterprise/2/html-single/Deployment_Guide/index.html#sect-Installing_and_Configuring_DNS_Plug-ins

Please re-open if more specific information is required.

Note You need to log in before you can comment on or make changes to this bug.