Bug 986016 - perl-MooseX-ClassAttribute-0.26 broken w/shipped perl-Moose-2.0802
perl-MooseX-ClassAttribute-0.26 broken w/shipped perl-Moose-2.0802
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-MooseX-ClassAttribute (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 14:33 EDT by Graham TerMarsch
Modified: 2013-08-16 19:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-MooseX-ClassAttribute-0.27-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 19:00:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham TerMarsch 2013-07-18 14:33:31 EDT
Description of problem:

The version of MooseX::ClassAttribute currently distributed (0.26) does not work at all with the version of Moose that is shipped with Fedora-19 (Moose 2.0802).

Even attempting to rebuild the SRPM "perl-MooseX-ClassAttribute-0.26-7.fc19.src.rpm" against the shipped version of Moose fails.

A fix for this *is* available in the current 0.27 release of MooseX::ClassAttribute; simply moving to the latest version will remedy the situation.

Version-Release number of selected component (if applicable):

How reproducible:

Always.  Attempting to use MooseX::ClassAttribute on Fedora 19 fails outright.

Steps to Reproduce:
1. Try to rebuild the SRPM for 0.26; tests fail against shipped Moose-2.0802

Actual results:

Any use of MooseX::ClassAttribute fails.
e.g. SRPM fails to rebuild, due to failing tests.

Expected results:

SRPM rebuilds successfully.

Additional info:
Comment 1 Fedora Update System 2013-08-03 11:53:38 EDT
perl-MooseX-ClassAttribute-0.27-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-MooseX-ClassAttribute-0.27-1.fc19
Comment 2 Fedora Update System 2013-08-03 11:53:46 EDT
perl-MooseX-ClassAttribute-0.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-MooseX-ClassAttribute-0.27-1.fc18
Comment 3 Fedora Update System 2013-08-03 20:05:59 EDT
Package perl-MooseX-ClassAttribute-0.27-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-MooseX-ClassAttribute-0.27-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14193/perl-MooseX-ClassAttribute-0.27-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-16 19:00:02 EDT
perl-MooseX-ClassAttribute-0.27-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-08-16 19:02:19 EDT
perl-MooseX-ClassAttribute-0.27-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.