Bug 986061 - Unable to switch keyboard layout in Cinnamon
Unable to switch keyboard layout in Cinnamon
Status: CLOSED DUPLICATE of bug 985763
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 17:38 EDT by Leonid Kanter
Modified: 2013-07-18 18:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 18:01:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2013-07-18 17:38:45 EDT
Description of problem:

I need to use us and ru keyboard layouts. Tried to configure group switch in gnome-settings and setxkbmap command line - both methods do not work in cinnamon, other desktops are ok.


Version-Release number of selected component (if applicable):

cinnamon-1.9.1-16.fc19

How reproducible:

Always

Steps to Reproduce:
1. In GNOME, go to Settings, Keyboard, add Russian layout, in Shortcuts tab go to Typing, and for "modifiers-only switch to next source" select Ctrl+Shift
2. Try to change groups by pressing ctrl+shift in any text input field
3. Switch from GNOME to Cinnamon

Actual results:

Switch has no effect

Expected results:

Selected layout switch should work in cinnamon too

Additional info:

Tried following terminal command:

setxkbmap -layout us,ru -variant ,winkeys -option   grp:ctrl_shift_toggle

It has no effect in cinnamot too but works in other DE.
Comment 1 leigh scott 2013-07-18 18:01:08 EDT

*** This bug has been marked as a duplicate of bug 985763 ***

Note You need to log in before you can comment on or make changes to this bug.