Bug 986087 - Installation of npm fails with dependencies error
Installation of npm fails with dependencies error
Status: CLOSED DUPLICATE of bug 985305
Product: Fedora
Classification: Fedora
Component: nodejs-lru-cache (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: T.C. Hollingsworth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 19:37 EDT by Ghislain Hachey
Modified: 2013-07-20 11:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 11:05:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ghislain Hachey 2013-07-18 19:37:36 EDT
Description of problem:

The installation of npm fails consistently on Fedora 18 64-bit.

Version-Release number of selected component (if applicable):

npm-1.2.14-2.fc18.noarch requires lru-cache <2.3 but...
nodejs-lru-cache-2.3.0-3.fc18.noarch is the one being installed.

How reproducible:

I only tried on my system.

Steps to Reproduce:
1. yum update
2. yum install npm
3.

I actually installnodejs first.

1. yum update
2. yum install nodejs
3. yum install npm

Actual results:

--> Finished Dependency Resolution
Error: Package: npm-1.2.14-2.fc18.noarch (updates)
           Requires: npm(lru-cache) < 2.3
           Installing: nodejs-lru-cache-2.3.0-3.fc18.noarch (updates)
               npm(lru-cache) = 2.3.0
Error: Package: npm-1.2.14-2.fc18.noarch (updates)
           Requires: npm(lru-cache) < 2.3
           Available: nodejs-lru-cache-2.3.0-3.fc18.noarch (updates)
               npm(lru-cache) = 2.3.0
Error: Package: nodejs-read-package-json-0.2.2-1.fc18.noarch (updates)
           Requires: npm(lru-cache) < 2.3
           Installing: nodejs-lru-cache-2.3.0-3.fc18.noarch (updates)
               npm(lru-cache) = 2.3.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Cleanly resolve dependencies and install.

Additional info:
Comment 1 Ghislain Hachey 2013-07-18 20:11:08 EDT
Sorry, just found bug #905814 which is a duplicate. Using the testing repo works.

# yum --enablerepo=updates-testing install npm

as a work around for now.
Comment 2 Chad Feller 2013-07-20 10:58:14 EDT
Seeing same thing on updates of existing installs:

Resolving Dependencies
--> Running transaction check
---> Package nodejs-lru-cache.noarch 0:2.2.2-1.fc18 will be updated
--> Processing Dependency: npm(lru-cache) < 2.3 for package: npm-1.2.14-2.fc18.noarch
--> Processing Dependency: npm(lru-cache) < 2.3 for package: nodejs-read-package-json-0.2.2-1.fc18.noarch
---> Package nodejs-lru-cache.noarch 0:2.3.0-3.fc18 will be an update
--> Finished Dependency Resolution
Error: Package: npm-1.2.14-2.fc18.noarch (@updates)
           Requires: npm(lru-cache) < 2.3
           Removing: nodejs-lru-cache-2.2.2-1.fc18.noarch (@updates)
               npm(lru-cache) = 2.2.2
           Updated By: nodejs-lru-cache-2.3.0-3.fc18.noarch (updates)
               npm(lru-cache) = 2.3.0
Error: Package: nodejs-read-package-json-0.2.2-1.fc18.noarch (@updates)
           Requires: npm(lru-cache) < 2.3
           Removing: nodejs-lru-cache-2.2.2-1.fc18.noarch (@updates)
               npm(lru-cache) = 2.2.2
           Updated By: nodejs-lru-cache-2.3.0-3.fc18.noarch (updates)
               npm(lru-cache) = 2.3.0
 You could try using --skip-broken to work around the problem
Comment 3 T.C. Hollingsworth 2013-07-20 11:05:47 EDT
You can install npm 1.3.3 from updates-testing as explained above, or you can wait until Monday, when I'll be able to push the update stable.

If the updates-testing version is working for you, please log in and provide karma to this update so it can get pushed stable faster:
https://admin.fedoraproject.org/updates/FEDORA-2013-11780

Thanks and sorry for the trouble.

*** This bug has been marked as a duplicate of bug 985305 ***

Note You need to log in before you can comment on or make changes to this bug.