Bug 986092 - Messages marked as junk reappear in Inbox
Messages marked as junk reappear in Inbox
Status: CLOSED DUPLICATE of bug 960213
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
18
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 19:57 EDT by Per Nystrom
Modified: 2013-07-22 04:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 674208
Environment:
Last Closed: 2013-07-22 04:29:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 650293 None None None Never

  None (edit)
Description Per Nystrom 2013-07-18 19:57:05 EDT
+++ This bug was initially created as a clone of Bug #674208 +++

Description of problem:

Some of the email I mark as junk mysteriously makes its way back into my Inbox.

Version-Release number of selected component (if applicable):

# rpm -q evolution
evolution-2.32.1-1.fc14.x86_64

How reproducible:

Uncertain

Steps to Reproduce:
1. Select some messages in Inbox
2. Right-click, Mark as Junk
3. Wait a while (seems to be after a mailbox refresh)
  
Actual results:

Junk messages reappear in Inbox

Expected results:

Junk messages should stay in Junk mailbox

Additional info:

--- Additional comment from Milan Crha on 2011-02-01 03:05:33 EST ---

Thanks for a bug report. What account type is the Inbox from, please? Is it under On This Computer/Inbox, or in some IMAP/Inbox,...? If this is from On This Computer, where is the message from, is it just a copied message from other account, or a POP3 message?

Just in case, could you run evolution from terminal, reproduce the issue and check what is the output on the terminal, please? If there is something broken in the folder summary, which is preventing to save the value, then you may see some warnings on the console about that.

--- Additional comment from Matthew Barnes on 2011-02-01 07:43:48 EST ---

I've been seeing this bug myself with IMAP+.

If I mark messages as junk and leave Inbox open long enough, they stay gone and appear in my Junk folder.  If I mark messages as junk and then switch to a different folder and then back to Inbox, the junk messages remain in Inbox and do not appear in my Junk folder.

Marking the messages for deletion, however, does seem to be permanent.

Seems to be some sort of server sync issue.

--- Additional comment from Vitaly Bordug on 2011-07-01 18:54:10 EDT ---

more information - junk messages reappeared after evolution close and open again. This is actual on F15 as well by the way. Junk tag is lost. The INBOX has been explicitly expunged before exit.

Check with another IMAP client showed that messages are really moved out from INBOX. But exiting the client cause them to reappear back, Junk folder becomes empty in turn.

This makes junk controls pretty useless.

Nothing strange in console output at all, no errors etc.

--- Additional comment from Vitaly Bordug on 2011-07-01 19:09:34 EDT ---

Another update. Change filtering to SA from bogofilter seems to help. Now messages are placed to junk. So I think this issue is relevant for respective spam filtering plugin.

However fresh-install-default configuration just doesn't work that might deserve a look.

--- Additional comment from Ross Vandegrift on 2011-07-13 13:41:46 EDT ---

I've been seeing this issue with Evolution 2.32 on Debian wheezy.  For other information seekers:

1) It only ever affected my IMAP account which is stored on MS Exchange.  Two other accounts (one served by dovecot, the other by gmail) were never affected.

2) Switching to SpamAssassin also fixed the issue.

Ross

--- Additional comment from Vitaly Bordug on 2011-07-13 13:48:43 EDT ---

qmail here. 

Well I observed such with SpamAssassin as well - only not that frequent.

--- Additional comment from Milan Crha on 2011-07-25 11:59:57 EDT ---

Thanks for the update. There is a corresponding upstream bug [1] for the same, thus I'm moving it there. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=650293

This is happening again with Fedora 18

# rpm -qa 'evolution*'
evolution-ews-3.6.4-1.fc18.x86_64
evolution-spamassassin-3.6.4-3.fc18.x86_64
evolution-3.6.4-3.fc18.x86_64
evolution-help-3.6.4-3.fc18.noarch
evolution-data-server-3.6.4-4.fc18.x86_64
Comment 1 Milan Crha 2013-07-19 03:06:04 EDT
(In reply to Per Nystrom from comment #0)
> This is happening again with Fedora 18
> 
> # rpm -qa 'evolution*'
> evolution-ews-3.6.4-1.fc18.x86_64
> evolution-spamassassin-3.6.4-3.fc18.x86_64
> evolution-3.6.4-3.fc18.x86_64
> evolution-help-3.6.4-3.fc18.noarch
> evolution-data-server-3.6.4-4.fc18.x86_64

Thanks for a bug report. I'm not sure whether this is about the same issue as almost two years ago. I see you use evolution-ews, but the original bug report was reported against IMAP+. What is your case, please?
Comment 2 Per Nystrom 2013-07-19 11:22:37 EDT
The account on which I see this behavior is IMAP+
Comment 3 Milan Crha 2013-07-22 04:29:26 EDT
Thanks for the update. In that case this is supposed to be fixed within (an upstream bug for it) bug #960213.

*** This bug has been marked as a duplicate of bug 960213 ***

Note You need to log in before you can comment on or make changes to this bug.