Bug 986099 - [RFE] Switch to using oslo's db support
[RFE] Switch to using oslo's db support
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
high Severity unspecified
: Upstream M2
: 4.0
Assigned To: Maru Newby
Rami Vaknin
https://blueprints.launchpad.net/neut...
: FutureFeature
Depends On: 988867
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-07-18 21:05 EDT by Maru Newby
Modified: 2016-04-26 11:00 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-0.3.b2.el6ost
Doc Type: Enhancement
Doc Text:
The following changes in configuration have been made as part of moving to the oslo library, and affect all OpenStack Networking (Neutron) plugins. - the 'DATABASE' section in the plugin-specific ini files has been deprecated in favor of a 'database' section in neutron.conf. - 'sql_' prefixed options have been deprecated in favor of options that do not include the prefix (e.g. sql_connection becomes connection). - 'reconnect_interval' option has been deprecated in favor of 'retry_interval'. - 'sql_dbpool_enable' option is no longer supported. - 'sqlalchemy_pool_size' has been deprecated in favor of 'min_pool_size' and 'max_pool_size'. - 'sqlalchemy_max_overflow' has been deprecated in favor of 'max_overflow'. - 'sqlalchemy_pool_timeout' has been deprecated in favor of 'pool_timeout'. The changes are backwards compatible, so the previous configuration format will still work.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:13:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oblaut: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Maru Newby 2013-07-18 21:05:22 EDT
The oslo library provides database helpers that can be reused across projects.  The switch should be transparent to the end user due to support for backwards-compatible configuration, but the new oslo-specific configuration will need to be documented.

https://blueprints.launchpad.net/neutron/+spec/oslo-db-support
Comment 5 Maru Newby 2013-07-30 13:31:11 EDT
Ofer - There isn't a need for special testing.  If the higher-level neutron tests work, then the db implementation works.  This bug is mainly to ensure that the docs are updated to reflect changes to configuration.
Comment 11 Maru Newby 2013-12-09 22:06:22 EST
There is no user-visible functional change associated with this bug, but the configuration format has been changed in a backwards-compatible way.
Comment 13 errata-xmlrpc 2013-12-19 19:13:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.