Bug 98610 - can't lvcreate in specific raid physical volumes
Summary: can't lvcreate in specific raid physical volumes
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Heinz Mauelshagen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 116727
TreeView+ depends on / blocked
 
Reported: 2003-07-04 21:56 UTC by Alexandre Oliva
Modified: 2007-11-30 22:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 17:09:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2003-07-04 21:56:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030619

Description of problem:
If you specify a raid block device as the physical volume to use for a logical
volume to be created, it fails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set up a volume group say VG00 containing at least one physical volume that is
a raid device say /dev/md0, with at least one free logical extent
2.lvcreate -n test -l 1 VG00 /dev/md0

Actual Results:  lvcreate -- couldn't read physical volume "/dev/md0"


Expected Results:  It works for non-raid physical volumes (say /dev/hda5), so it
should work for raid devices too.

Additional info:

This has been broken since at least Shrike.

Comment 1 Bastien Nocera 2004-03-02 15:25:19 UTC
Does running:
lvcreate -n test -l 1 VG00
with /dev/md0 in the VG00 group work?

Comment 2 Alexandre Oliva 2004-03-02 19:06:15 UTC
Yup.  And even if there were only raid devices in the volume group, it
would still work.  It doesn't seem to be a problem with using raid
devices or allocating blocks to them, it's probably more of a matter
of handling command-line arguments.

Comment 3 Heinz Mauelshagen 2004-03-03 09:49:55 UTC
*** Bug 117279 has been marked as a duplicate of this bug. ***

Comment 6 Heinz Mauelshagen 2004-04-22 14:06:18 UTC
Fix is in dist-10-updates-candidate for test.


Note You need to log in before you can comment on or make changes to this bug.