Bug 98612 - installing on low-memory machine with swap on logical volume fails
installing on low-memory machine with swap on logical volume fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-04 19:16 EDT by Alexandre Oliva
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:16:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-07-04 19:16:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030619

Description of problem:
If anaconda finds that the machine has too little memory, it decides to enable
swap right after partitioning the system in disk druid.  However, if any swap
devices are logical volumes, this procedure fails, because the logical volume
still hasn't been activated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start installer on a machine with say 64MB or 96MB of memory (year, lower than
minimum recommended)
2.Preserve a pre-existing swap logical volume while partitioning the system (and
don't create any other swap elements, just in case)
3.Tell anaconda it's ok to commit to the new partitioning and start swap early

Actual Results:  The attempt to bring up the swap partition fails

Expected Results:  It should probably ask the user to set up at least a certain
amount of non-LV-dependent swap space, and not enable that too early.  Or, even
better, it should vgchange -a y <vgname> such that it can actually activate the
swap logical volume early.

Additional info:

Switching to VT1 and running the vgchange command above, after disk druid is
started, but before we proceed to the next part of the installation, works, as
long as the swap LV already existed before, and we don't ``repartition'' the VG.
Comment 2 Jeremy Katz 2004-10-04 23:16:10 EDT
This should (I think) be resolved in current releases.
Comment 3 Alexandre Oliva 2004-10-05 08:00:22 EDT
All the boxes that used to trigger this error were retired some weeks
ago, but I vaguely remember I succeeded in installing FC2 on the last
of these boxes, and I think it had swap on LVM.  Thanks,

Note You need to log in before you can comment on or make changes to this bug.