Bug 986141 - rkill instead of kill in alsa-state.service
rkill instead of kill in alsa-state.service
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 00:06 EDT by Brendan Jones
Modified: 2013-07-27 21:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: alsa-utils-1.0.27.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 21:12:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brendan Jones 2013-07-19 00:06:04 EDT
Hi,

noticed this in the journal:

Jul 18 21:38:45 fedora19.bjnet kernel: alsactl[420]: segfault at 28 ip 0000000000410919 sp 00007fff3ddf84a0 error 4 in alsactl[400000+16000]
Jul 18 21:38:45 fedora19.bjnet alsactl[25162]: alsactl: Unknown command 'rkill'...

Should alsa-state.service be issuing 

ExecStop=-/usr/sbin/alsactl -s kill save_and_quit

rather than:

ExecStop=-/usr/sbin/alsactl -s kill save_and_quit

Note, upstream tracker seems to be down.
Comment 1 Fedora Update System 2013-07-24 03:58:33 EDT
alsa-utils-1.0.27.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/alsa-utils-1.0.27.2-2.fc19
Comment 2 Fedora Update System 2013-07-24 20:48:03 EDT
Package alsa-utils-1.0.27.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing alsa-utils-1.0.27.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13583/alsa-utils-1.0.27.2-2.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-07-27 21:12:44 EDT
alsa-utils-1.0.27.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.