Bug 986154 - packstack install fails with "LoadError: no such file to load -- puppet/util/command_line"
Summary: packstack install fails with "LoadError: no such file to load -- puppet/util/...
Status: CLOSED DUPLICATE of bug 985208
Alias: None
Product: Fedora
Classification: Fedora
Component: openstack-packstack   
(Show other bugs)
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Derek Higgins
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-19 05:32 UTC by Gowrishankar Rajaiyan
Modified: 2013-07-22 06:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 06:08:55 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openstack-setup.log (88.06 KB, text/plain)
2013-07-19 05:34 UTC, Gowrishankar Rajaiyan
no flags Details

Description Gowrishankar Rajaiyan 2013-07-19 05:32:52 UTC
Description of problem:


Version-Release number of selected component (if applicable):
puppet-3.1.1-4.fc19.noarch
Packstack: last commit "0ca7d5ac37858e1d5e16c6988fd12296d4f0aba7"

How reproducible:


Steps to Reproduce:
1. Install Fedora 19
2. git clone --recursive git://github.com/stackforge/packstack.git
3. cd packstack
4. ./bin/packstack --gen-answer-file=ans.txt
5. update ans.txt:
 5.1 CONFIG_CINDER_BACKEND=gluster
 5.2 CONFIG_CINDER_GLUSTER_MOUNTS=10.65.201.186:/cinder-vol
6. ./bin/packstack --answer-file=ans.txt

Actual results:
ERROR : Error during puppet run : LoadError: no such file to load -- puppet/util/command_line
Please check log file /var/tmp/packstack/20130719-214349-IGB2ML/openstack-setup.log for more information

Expected results:


Additional info:
2013-07-19 21:45:50::ERROR::ospluginutils::143::root:: Error  during remote puppet apply of /var/tmp/packstack/20130719-214349-IGB2ML/manifests/10.65.201.146_prescript.pp
2013-07-19 21:45:50::ERROR::ospluginutils::144::root:: LoadError: no such file to load -- puppet/util/command_line
  require at org/jruby/RubyKernel.java:1027
  require at /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45
   (root) at /usr/bin/puppet:3

2013-07-19 21:45:50::DEBUG::sequences::48::root:: Traceback (most recent call last):
  File "bin/../packstack/installer/core/sequences.py", line 46, in run
    self.function(config)
  File "/root/packstack/packstack/plugins/puppet_950.py", line 191, in applyPuppetManifest
    waitforpuppet(currently_running)
  File "/root/packstack/packstack/plugins/puppet_950.py", line 178, in waitforpuppet
    validate_puppet_logfile(log)
  File "bin/../packstack/modules/ospluginutils.py", line 145, in validate_puppet_logfile
    raise PackStackError(message)
PackStackError: Error during puppet run : LoadError: no such file to load -- puppet/util/command_line

2013-07-19 21:45:50::ERROR::run_setup::898::root:: Traceback (most recent call last):
  File "bin/../packstack/installer/run_setup.py", line 893, in main
    _main(confFile)
  File "bin/../packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "bin/../packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "bin/../packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "bin/../packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "bin/../packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : LoadError: no such file to load -- puppet/util/command_line

Comment 1 Gowrishankar Rajaiyan 2013-07-19 05:34:13 UTC
Created attachment 775638 [details]
openstack-setup.log

Comment 2 Gowrishankar Rajaiyan 2013-07-19 06:03:01 UTC
Apparently I has to do "yum install ruby". Shouldn't this be part of "Installing Dependencies..." ?

Comment 3 Martin Magr 2013-07-22 06:08:55 UTC

*** This bug has been marked as a duplicate of bug 985208 ***


Note You need to log in before you can comment on or make changes to this bug.