Bug 986201 - Unable to get effective pom when using dependencies defined in cxf parent bom
Unable to get effective pom when using dependencies defined in cxf parent bom
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build, Maven Repository (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: ER4
: EAP 6.1.1
Assigned To: Paul Gier
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 04:34 EDT by Rostislav Svoboda
Modified: 2013-09-16 16:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:27:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rostislav Svoboda 2013-07-19 04:34:01 EDT
Issue related to CXF build - cxf parent and defined dependencies issue when receiving effective pom from test pom which imports all dependencies from cxf parent. 

dependencies.dependency.version and expression problems like this: 
  'dependencies.dependency.version' for org.jboss.spec.javax.servlet:${cxf.servlet-api-2.5.artifact}:jar is missing. @ line 75, column 13

Test pom file available on http://pastebin.test.redhat.com/154128

See http://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Repository/job/eap-60-repository-maven-check-boms-for-effective-pom/78/testReport/cxf-parent-2.6.8-redhat-1/pom-BOM-test/cxf_parent_2_6_8_redhat_1_pom_BOM_test/

Error details available too in http://pastebin.test.redhat.com/154126
Comment 1 Rostislav Svoboda 2013-07-22 10:58:59 EDT
locker proposal because we are in 'blockers only' mode
Comment 2 Paul Gier 2013-07-23 16:31:36 EDT
This should be fixed with the latest build of apache cxf (2.6.8-redhat-3).
https://brewweb.devel.redhat.com/buildinfo?buildID=283080
Comment 3 Nikoleta Ziakova 2013-08-05 09:30:54 EDT
Verified for EAP 6.1.1 ER4.
Note: since the build of apache cxf that fixes this issue there is new problem in maven repo - artifact is not named correctly - https://bugzilla.redhat.com/show_bug.cgi?id=993037

Note You need to log in before you can comment on or make changes to this bug.