Bug 986206 - Incompatible Netty versions strings between Netty and HornetQ
Incompatible Netty versions strings between Netty and HornetQ
Status: CLOSED DUPLICATE of bug 986195
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Paul Gier
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 04:41 EDT by Martin Svehla
Modified: 2013-07-19 04:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-19 04:43:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Svehla 2013-07-19 04:41:09 EDT
Description of problem:

hornetq-core-client-2.3.2.Final-redhat-1.jar expects Netty version 3.6.6.Final-redhat-1-90e1eb2, but netty-3.6.6.Final-redhat-1.jar provides version id 
3.6.6.Final-redhat-1-fd3c6b7.


Version-Release number of selected component:

EAP 6.1.1.ER3, HornetQ 2.3.2.Final, Netty 3.6.6.Final


Expected results:

Unpack hornetq-version.properties from hornetq-core-client jar. hornetq.netty.version is 3.6.6.Final-redhat-1-90e1eb2.

Unpack netty jar and run javap -constants org.jboss.netty.util.Version. Output is:
Compiled from "Version.java"
public final class org.jboss.netty.util.Version {
  public static final java.lang.String ID = "3.6.6.Final-redhat-1-fd3c6b7";
  public static void main(java.lang.String[]);
}

Both netty version strings should be same.
Comment 1 Martin Svehla 2013-07-19 04:43:31 EDT

*** This bug has been marked as a duplicate of bug 986195 ***

Note You need to log in before you can comment on or make changes to this bug.